CVE-2023-26103 Regular Expression Denial of Service in Deno.upgradeWebSocket API

Medium 5.3 Published Updated

Attackers can cause denial of service in Deno WebSocket servers by sending specially crafted headers that trigger expensive regex processing.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-26103?

CVE-2023-26103 is a medium-severity denial of service vulnerability in deno, published on 25 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Versions of the package deno before 1.31.0 are vulnerable to Regular Expression Denial of Service (ReDoS) due to the upgradeWebSocket function, which contains regexes in the form of /s*,s*/, used for splitting the Connection/Upgrade header. A specially crafted Connection/Upgrade header can be used to significantly slow down a web socket server.

Weakness: CWE-1333

Which versions are affected by CVE-2023-26103?

2 open source packages ship an affected version, including deno. It affects 1 product.

PackageAffectedFixed in
deno crates.ioFrom 1.12.01.31.0
deno crates.ioFrom 1.12.01.31.0

Products include Deno Deno.

How do I fix CVE-2023-26103?

Upgrade deno to 1.31.0 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-26103 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26103 exists.

Sources

Also known as GHSA-jc97-h3h9-7xh6, JLSEC-2026-101.

Is CVE-2023-26103 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free