{"answers":{"affected":"2 open source packages ship an affected version, including deno. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26103 exists.","fix":"Upgrade deno to 1.31.0 or later.","what":"CVE-2023-26103 is a medium-severity denial of service vulnerability in deno, published on 25 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-26103 and fix it if it is affected.\n\nWhat it is: CVE-2023-26103 is a medium-severity denial of service vulnerability in deno, published on 25 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26103 exists.\n\nAffected packages and fixed versions:\n- deno (crates.io): affected from 1.12.0; fixed in 1.31.0\n- deno (crates.io): affected from 1.12.0; fixed in 1.31.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-26103/ (Markdown: https://insights.sbomify.com/CVE-2023-26103/index.md)","id":"CVE-2023-26103","markdown":"https://insights.sbomify.com/CVE-2023-26103/index.md","name":"CVE-2023-26103","record":{"aliases":["GHSA-jc97-h3h9-7xh6","JLSEC-2026-101"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Deno runtime","requires_auth":"none","summary":"Attackers can cause denial of service in Deno WebSocket servers by sending specially crafted headers that trigger expensive regex processing.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"deno","vendor":"deno"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"Versions of the package deno before 1.31.0 are vulnerable to Regular Expression Denial of Service (ReDoS) due to the upgradeWebSocket function, which contains regexes in the form of /s*,s*/, used for splitting the Connection/Upgrade header. A specially crafted Connection/Upgrade header can be used to significantly slow down a web socket server.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Regular Expression Denial of Service in Deno.upgradeWebSocket API","id":"CVE-2023-26103","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":2,"n_references":5,"next":{"headline":"Denial of Service vulnerability in lite-web-server","id":"CVE-2023-26104"},"packages":[{"ecosystem":"crates.io","fixed":["1.31.0"],"introduced":["1.12.0"],"last_affected":[],"package":"deno","purl":null,"source":"GHSA-jc97-h3h9-7xh6"},{"ecosystem":"crates.io","fixed":["1.31.0"],"introduced":["1.12.0"],"last_affected":[],"package":"deno","purl":"pkg:cargo/deno","source":"GHSA-jc97-h3h9-7xh6"}],"prev":{"headline":"rangy vulnerable to Prototype Pollution","id":"CVE-2023-26102"},"products":["deno"],"published":"2023-02-25","related":[{"cvss_score":10,"headline":"Deno improperly handles resizable ArrayBuffer","id":"CVE-2023-28445","kev_date_added":null,"published":"2023-03-23"},{"cvss_score":10,"headline":"Sandbox bypass leading to arbitrary code execution in Deno","id":"CVE-2022-24783","kev_date_added":null,"published":"2022-03-25"},{"cvss_score":9.8,"headline":"Static imports inside dynamically imported modules do not adhere to permission checks","id":"CVE-2021-32619","kev_date_added":null,"published":"2021-05-28"},{"cvss_score":9.2,"headline":"Deno node:crypto doesn't finalize cipher","id":"CVE-2026-22863","kev_date_added":null,"published":"2026-01-15"},{"cvss_score":8.8,"headline":"Deno interactive permission prompt spoofing via improper ANSI stripping","id":"CVE-2024-27936","kev_date_added":null,"published":"2024-03-06"},{"cvss_score":8.8,"headline":"Deno is vulnerable to interactive `run` permission prompt spoofing via improper ANSI neutralization","id":"CVE-2023-28446","kev_date_added":null,"published":"2023-03-24"},{"cvss_score":8.6,"headline":"Deno missing \"--allow-net\" permission check for built-in Node modules","id":"CVE-2023-33966","kev_date_added":null,"published":"2023-05-31"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-11","vendors":["n/a"]},"summary":"Attackers can cause denial of service in Deno WebSocket servers by sending specially crafted headers that trigger expensive regex processing.","url":"https://insights.sbomify.com/CVE-2023-26103/"}