# CVE-2023-26103: Regular Expression Denial of Service in Deno.upgradeWebSocket API

> Attackers can cause denial of service in Deno WebSocket servers by sending specially crafted headers that trigger expensive regex processing.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Feb 2023
- **Updated:** 11 Mar 2025
- **Also known as:** GHSA-jc97-h3h9-7xh6, JLSEC-2026-101

## What is CVE-2023-26103?

CVE-2023-26103 is a medium-severity denial of service vulnerability in deno, published on 25 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of the package deno before 1.31.0 are vulnerable to Regular Expression Denial of Service (ReDoS) due to the upgradeWebSocket function, which contains regexes in the form of /s*,s*/, used for splitting the Connection/Upgrade header. A specially crafted Connection/Upgrade header can be used to significantly slow down a web socket server.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2023-26103?

2 open source packages ship an affected version, including deno. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `deno` | crates.io | From 1.12.0 | 1.31.0 |
| `deno` | crates.io | From 1.12.0 | 1.31.0 |

Products: Deno Deno.

## How do I fix CVE-2023-26103?

Upgrade deno to 1.31.0 or later.

## Is CVE-2023-26103 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26103 exists.

## Other vulnerabilities in deno

- [CVE-2023-28445](https://insights.sbomify.com/CVE-2023-28445/): Deno improperly handles resizable ArrayBuffer (critical 10.0)
- [CVE-2022-24783](https://insights.sbomify.com/CVE-2022-24783/): Sandbox bypass leading to arbitrary code execution in Deno (critical 10.0)
- [CVE-2021-32619](https://insights.sbomify.com/CVE-2021-32619/): Static imports inside dynamically imported modules do not adhere to permission checks (critical 9.8)
- [CVE-2026-22863](https://insights.sbomify.com/CVE-2026-22863/): Deno node:crypto doesn't finalize cipher (critical 9.2)
- [CVE-2024-27936](https://insights.sbomify.com/CVE-2024-27936/): Deno interactive permission prompt spoofing via improper ANSI stripping (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-26103 and fix it if it is affected.

What it is: CVE-2023-26103 is a medium-severity denial of service vulnerability in deno, published on 25 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26103 exists.

Affected packages and fixed versions:
- deno (crates.io): affected from 1.12.0; fixed in 1.31.0
- deno (crates.io): affected from 1.12.0; fixed in 1.31.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-26103/ (Markdown: https://insights.sbomify.com/CVE-2023-26103/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-26103
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-26103
- OSV: https://osv.dev/vulnerability/CVE-2023-26103

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-26103/
Summaries are generated and may contain mistakes; the official description above is the record.
