# CVE-2023-26112: configobj ReDoS exploitable by developer using values in a server-side configuration file

> A Regular Expression Denial of Service vulnerability in the configobj library allows attackers to cause service disruption via malicious configuration values.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Apr 2023
- **Updated:** 13 Feb 2025
- **Also known as:** DEBIAN-CVE-2023-26112, GHSA-c33w-24p9-8m24, MINI-4hc4-rchx-5f9j, PYSEC-2026-1270, SUSE-SU-2023:3368-1, SUSE-SU-2023:3369-1, UBUNTU-CVE-2023-26112, USN-7040-1, USN-7040-2, openSUSE-SU-2024:13199-1, openSUSE-SU-2026:12005-1

## What is CVE-2023-26112?

CVE-2023-26112 is a low-severity denial of service vulnerability in configobj, published on 3 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

All versions of the package configobj are vulnerable to Regular Expression Denial of Service (ReDoS) via the validate function, using (.+?)\((.*)\).**Note:** This is only exploitable in the case of a developer, putting the offending value in a server side configuration file.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2023-26112?

3 open source packages ship an affected version, including configobj. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `configobj` | PyPI | All versions | 5.0.9 |
| `configobj` | PyPI | All versions | 5.0.9 |
| `configobj` | PyPI | All versions | 5.0.9 |
| `python-configobj` | SUSE:Linux Enterprise Micro 5.4 | All versions | 5.0.6-150000.3.3.1 |
| `python-configobj` | SUSE:Linux Enterprise Module for Basesystem 15 SP4 | All versions | 5.0.6-150000.3.3.1 |
| `python-configobj` | SUSE:Linux Enterprise Module for Basesystem 15 SP5 | All versions | 5.0.6-150000.3.3.1 |
| `python-configobj` | SUSE:Linux Enterprise Module for Public Cloud 12 | All versions | 5.0.6-20.8.1 |
| `python-configobj` | SUSE:Linux Enterprise Real Time 15 SP3 | All versions | 5.0.6-150000.3.3.1 |
| `python-configobj` | SUSE:Linux Enterprise Server 12 SP5 | All versions | 5.0.6-20.8.1 |
| `python-configobj` | SUSE:Linux Enterprise Server for SAP Applications 12 SP5 | All versions | 5.0.6-20.8.1 |
| `python-configobj` | SUSE:Manager Proxy 4.2 | All versions | 5.0.6-150000.3.3.1 |
| `python-configobj` | SUSE:Manager Server 4.2 | All versions | 5.0.6-150000.3.3.1 |
| `python-configobj` | openSUSE:Leap 15.4 | All versions | 5.0.6-150000.3.3.1 |
| `python-configobj` | openSUSE:Leap 15.5 | All versions | 5.0.6-150000.3.3.1 |
| `python-configobj` | openSUSE:Leap Micro 5.4 | All versions | 5.0.6-150000.3.3.1 |
| `python-configobj` | openSUSE:Tumbleweed | All versions | 5.0.9-1.6 |

Products: Configobj Project Configobj.

## How do I fix CVE-2023-26112?

Upgrade configobj to 5.0.9 or later.

## Is CVE-2023-26112 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26112 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-26112 and fix it if it is affected.

What it is: CVE-2023-26112 is a low-severity denial of service vulnerability in configobj, published on 3 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26112 exists.

Affected packages and fixed versions:
- configobj (PyPI): affected all versions; fixed in 5.0.9
- configobj (PyPI): affected all versions; fixed in 5.0.9
- configobj (PyPI): affected all versions; fixed in 5.0.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-26112/ (Markdown: https://insights.sbomify.com/CVE-2023-26112/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-26112
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-26112
- OSV: https://osv.dev/vulnerability/CVE-2023-26112

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-26112/
Summaries are generated and may contain mistakes; the official description above is the record.
