{"answers":{"affected":"2 open source packages ship an affected version, including word-wrap. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26115 exists.","fix":"Upgrade word-wrap to 1.2.4 or later.","what":"CVE-2023-26115 is a medium-severity denial of service vulnerability in org.webjars.npm:word-wrap, published on 22 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-26115 and fix it if it is affected.\n\nWhat it is: CVE-2023-26115 is a medium-severity denial of service vulnerability in org.webjars.npm:word-wrap, published on 22 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26115 exists.\n\nAffected packages and fixed versions:\n- word-wrap (npm): affected all versions; fixed in 1.2.4\n- word-wrap (npm): affected all versions; fixed in 1.2.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-26115/ (Markdown: https://insights.sbomify.com/CVE-2023-26115/index.md)","id":"CVE-2023-26115","markdown":"https://insights.sbomify.com/CVE-2023-26115/index.md","name":"CVE-2023-26115","record":{"aliases":["AZL-43867","AZL-44184","CLSA-2026-1782954036","GHSA-j8xg-fqg3-53r7","MINI-hj27-vwh8-3gjj","ROOT-APP-NPM-CVE-2023-26115"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript word-wrap library","requires_auth":"none","summary":"Attackers can cause denial of service in applications using the word-wrap library by triggering inefficient regular expression processing.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"word-wrap","vendor":"word-wrap_project"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L/E:P","version":"3.1"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"All versions of the package word-wrap are vulnerable to Regular Expression Denial of Service (ReDoS) due to the usage of an insecure regular expression within the result variable.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"word-wrap vulnerable to Regular Expression Denial of Service","id":"CVE-2023-26115","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":2,"n_references":5,"next":{"headline":"angular vulnerable to regular expression denial of service via the angular.copy() utility","id":"CVE-2023-26116"},"packages":[{"ecosystem":"npm","fixed":["1.2.4"],"introduced":["0"],"last_affected":[],"package":"word-wrap","purl":null,"source":"GHSA-j8xg-fqg3-53r7"},{"ecosystem":"npm","fixed":["1.2.4"],"introduced":["0"],"last_affected":[],"package":"word-wrap","purl":"pkg:npm/word-wrap","source":"GHSA-j8xg-fqg3-53r7"}],"prev":{"headline":"code-server vulnerable to Missing Origin Validation in WebSockets","id":"CVE-2023-26114"},"products":["org.webjars.npm:word-wrap","word-wrap"],"published":"2023-06-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-13","vendors":["n/a"]},"summary":"Attackers can cause denial of service in applications using the word-wrap library by triggering inefficient regular expression processing.","url":"https://insights.sbomify.com/CVE-2023-26115/"}