# CVE-2023-26119: HtmlUnit Code Injection vulnerability

> Attacker can execute arbitrary code via XSTL when browsing a malicious webpage using the HTMLUnit library.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Apr 2023
- **Updated:** 8 Oct 2026
- **Also known as:** CLSA-2025-1766534901, GHSA-3xrr-7m6p-p7xh, ROOT-APP-MAVEN-CVE-2023-26119

## What is CVE-2023-26119?

CVE-2023-26119 is a critical code injection vulnerability in net.sourceforge.htmlunit:htmlunit, published on 3 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of the package net.sourceforge.htmlunit:htmlunit from 0 and before 3.0.0 are vulnerable to Remote Code Execution (RCE) via XSTL, when browsing the attacker’s webpage.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2023-26119?

2 open source packages ship an affected version, including net.sourceforge.htmlunit:htmlunit. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `net.sourceforge.htmlunit:htmlunit` | Maven | All versions | 3.0.0 |
| `net.sourceforge.htmlunit:htmlunit` | Maven | All versions | 3.0.0 |

Products: Htmlunit Htmlunit.

## How do I fix CVE-2023-26119?

Upgrade net.sourceforge.htmlunit:htmlunit to 3.0.0 or later.

## Is CVE-2023-26119 being exploited?

There is no known exploitation of CVE-2023-26119 in the wild and no public exploit code.

## Other vulnerabilities in net.sourceforge.htmlunit:htmlunit

- [CVE-2023-49093](https://insights.sbomify.com/CVE-2023-49093/): HtmlUnit vulnerable to Remote Code Execution (RCE) via XSTL (critical 9.8)
- [CVE-2023-2798](https://insights.sbomify.com/CVE-2023-2798/): Denial of service in HtmlUnit (high 7.5)
- [CVE-2022-29546](https://insights.sbomify.com/CVE-2022-29546/): OutOfMemory Exception by specifically crafted processing instruction in NekoHtml Parser (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-26119 and fix it if it is affected.

What it is: CVE-2023-26119 is a critical code injection vulnerability in net.sourceforge.htmlunit:htmlunit, published on 3 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-26119 in the wild and no public exploit code.

Affected packages and fixed versions:
- net.sourceforge.htmlunit:htmlunit (Maven): affected all versions; fixed in 3.0.0
- net.sourceforge.htmlunit:htmlunit (Maven): affected all versions; fixed in 3.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-26119/ (Markdown: https://insights.sbomify.com/CVE-2023-26119/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-26119
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-26119
- OSV: https://osv.dev/vulnerability/CVE-2023-26119

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-26119/
Summaries are generated and may contain mistakes; the official description above is the record.
