# CVE-2023-26132: dottie vulnerable to Prototype Pollution

> Prototype pollution in dottie allows attackers to modify object prototypes, potentially leading to code execution or privilege escalation.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jun 2023
- **Updated:** 6 Jan 2025
- **Also known as:** DEBIAN-CVE-2023-26132, GHSA-4gxf-g5gf-22h4, UBUNTU-CVE-2023-26132, USN-8041-1

## What is CVE-2023-26132?

CVE-2023-26132 is a high-severity vulnerability in dottie, published on 10 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of the package dottie before 2.0.4 are vulnerable to Prototype Pollution due to insufficient checks, via the set() function and the current variable in the /dottie.js file.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2023-26132?

2 open source packages ship an affected version, including dottie. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dottie` | npm | All versions | 2.0.4 |
| `dottie` | npm | All versions | 2.0.4 |

Products: Dottie Project Dottie.

## How do I fix CVE-2023-26132?

Upgrade dottie to 2.0.4 or later.

## Is CVE-2023-26132 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26132 exists.

## Other vulnerabilities in dottie

- [CVE-2026-27837](https://insights.sbomify.com/CVE-2026-27837/): Dottie vulnerable to prototype pollution bypass via non-first path segments in set() and transform() (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-26132 and fix it if it is affected.

What it is: CVE-2023-26132 is a high-severity vulnerability in dottie, published on 10 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26132 exists.

Affected packages and fixed versions:
- dottie (npm): affected all versions; fixed in 2.0.4
- dottie (npm): affected all versions; fixed in 2.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-26132/ (Markdown: https://insights.sbomify.com/CVE-2023-26132/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-26132
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-26132
- OSV: https://osv.dev/vulnerability/CVE-2023-26132

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-26132/
Summaries are generated and may contain mistakes; the official description above is the record.
