# CVE-2023-26133: progressbar.js vulnerable to Prototype Pollution

> Prototype pollution in progressbar.js allows attackers to modify object prototypes, potentially leading to code execution or privilege escalation.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:L/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jun 2023
- **Updated:** 6 Jan 2025
- **Also known as:** GHSA-89qm-hm2x-mxm3, ROOT-APP-NPM-CVE-2023-26133

## What is CVE-2023-26133?

CVE-2023-26133 is a high-severity vulnerability in progressbar.js, published on 12 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

All versions of the package progressbar.js are vulnerable to Prototype Pollution via the function extend() in the file utils.js.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2023-26133?

2 open source packages ship an affected version, including progressbar.js. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `progressbar.js` | npm | All versions | 1.1.1 |
| `progressbar.js` | npm | All versions | 1.1.1 |

Products: Progressbar.js Project Progressbar.js.

## How do I fix CVE-2023-26133?

Upgrade progressbar.js to 1.1.1 or later.

## Is CVE-2023-26133 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26133 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-26133 and fix it if it is affected.

What it is: CVE-2023-26133 is a high-severity vulnerability in progressbar.js, published on 12 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26133 exists.

Affected packages and fixed versions:
- progressbar.js (npm): affected all versions; fixed in 1.1.1
- progressbar.js (npm): affected all versions; fixed in 1.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-26133/ (Markdown: https://insights.sbomify.com/CVE-2023-26133/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-26133
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-26133
- OSV: https://osv.dev/vulnerability/CVE-2023-26133

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-26133/
Summaries are generated and may contain mistakes; the official description above is the record.
