CVE-2023-26140 @excalidraw/excalidraw Cross-site Scripting vulnerability

Medium 6.1 Published Updated

An attacker can execute arbitrary scripts in a victim's browser by embedding malicious links in Excalidraw whiteboard objects.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-26140?

CVE-2023-26140 is a medium-severity cross-site scripting vulnerability in @excalidraw/excalidraw, published on 16 Aug 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Versions of the package @excalidraw/excalidraw from 0.0.0 are vulnerable to Cross-site Scripting (XSS) via embedded links in whiteboard objects due to improper input sanitization.

Weakness: CWE-79

Which versions are affected by CVE-2023-26140?

2 open source packages ship an affected version, including @excalidraw/excalidraw. It affects 1 product.

PackageAffectedFixed in
@excalidraw/excalidraw npmAll versions0.15.3
@excalidraw/excalidraw npmAll versions0.15.3

Products include Excalidraw Excalidraw.

How do I fix CVE-2023-26140?

Upgrade @excalidraw/excalidraw to 0.15.3 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2023-26140 being exploited?

There is no known exploitation of CVE-2023-26140 in the wild and no public exploit code.

Sources

Also known as GHSA-v7v8-gjv7-ffmr.

Is CVE-2023-26140 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free