CVE-2023-26141 sidekiq Denial of Service vulnerability
An attacker can cause excessive polling requests leading to denial of service by manipulating localStorage values in the Sidekiq dashboard.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-26141?
CVE-2023-26141 is a high-severity denial of service vulnerability in sidekiq, published on 14 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Versions of the package sidekiq before 7.1.3 are vulnerable to Denial of Service (DoS) due to insufficient checks in the dashboard-charts.js file. An attacker can exploit this vulnerability by manipulating the localStorage value which will cause excessive polling requests.
Which versions are affected by CVE-2023-26141?
4 open source packages ship an affected version, including sidekiq. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
sidekiq RubyGems | All versions | 6.5.10 |
sidekiq RubyGems | All versions | 6.5.10 |
sidekiq RubyGems | From 7.0.0 | 7.1.3 |
sidekiq RubyGems | From 7.0.0 | 7.1.3 |
Products include Contribsys Sidekiq.
How do I fix CVE-2023-26141?
Upgrade sidekiq to a fixed version for your release line: 6.5.10 or 7.1.3.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2023-26141 being exploited?
There is no known exploitation of CVE-2023-26141 in the wild and no public exploit code.
Other vulnerabilities in sidekiq
Sources
Also known as GHSA-3qc2-v3hp-6cv8.