{"answers":{"affected":"4 open source packages ship an affected version, including sidekiq. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-26141 in the wild and no public exploit code.","fix":"Upgrade sidekiq to a fixed version for your release line: 6.5.10 or 7.1.3.","what":"CVE-2023-26141 is a high-severity denial of service vulnerability in sidekiq, published on 14 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-26141 and fix it if it is affected.\n\nWhat it is: CVE-2023-26141 is a high-severity denial of service vulnerability in sidekiq, published on 14 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-26141 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sidekiq (RubyGems): affected all versions; fixed in 6.5.10\n- sidekiq (RubyGems): affected all versions; fixed in 6.5.10\n- sidekiq (RubyGems): affected from 7.0.0; fixed in 7.1.3\n- sidekiq (RubyGems): affected from 7.0.0; fixed in 7.1.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-26141/ (Markdown: https://insights.sbomify.com/CVE-2023-26141/index.md)","id":"CVE-2023-26141","markdown":"https://insights.sbomify.com/CVE-2023-26141/index.md","name":"CVE-2023-26141","record":{"aliases":["GHSA-3qc2-v3hp-6cv8"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby background job library","requires_auth":"none","summary":"An attacker can cause excessive polling requests leading to denial of service by manipulating localStorage values in the Sidekiq dashboard.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"sidekiq","vendor":"contribsys"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:P","version":"3.1"},"cwes":[{"id":"CWE-345","name":"Insufficient Verification of Data Authenticity"},{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"Versions of the package sidekiq before 7.1.3 are vulnerable to Denial of Service (DoS) due to insufficient checks in the dashboard-charts.js file. An attacker can exploit this vulnerability by manipulating the localStorage value which will cause excessive polling requests.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"sidekiq Denial of Service vulnerability","id":"CVE-2023-26141","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":4,"n_references":4,"next":{"headline":"Other in Crow","id":"CVE-2023-26142"},"packages":[{"ecosystem":"RubyGems","fixed":["6.5.10"],"introduced":["0"],"last_affected":[],"package":"sidekiq","purl":null,"source":"GHSA-3qc2-v3hp-6cv8"},{"ecosystem":"RubyGems","fixed":["6.5.10"],"introduced":["0"],"last_affected":[],"package":"sidekiq","purl":"pkg:gem/sidekiq","source":"GHSA-3qc2-v3hp-6cv8"},{"ecosystem":"RubyGems","fixed":["7.1.3"],"introduced":["7.0.0"],"last_affected":[],"package":"sidekiq","purl":null,"source":"GHSA-3qc2-v3hp-6cv8"},{"ecosystem":"RubyGems","fixed":["7.1.3"],"introduced":["7.0.0"],"last_affected":[],"package":"sidekiq","purl":"pkg:gem/sidekiq","source":"GHSA-3qc2-v3hp-6cv8"}],"prev":{"headline":"@excalidraw/excalidraw Cross-site Scripting vulnerability","id":"CVE-2023-26140"},"products":["sidekiq"],"published":"2023-09-14","related":[{"cvss_score":8.3,"headline":"Cross-site Scripting (XSS) - Reflected in sidekiq/sidekiq","id":"CVE-2023-1892","kev_date_added":null,"published":"2023-04-05"},{"cvss_score":7.5,"headline":"Denial of service in sidekiq","id":"CVE-2022-23837","kev_date_added":null,"published":"2022-01-21"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2023-46950","kev_date_added":null,"published":"2024-03-01"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2023-46951","kev_date_added":null,"published":"2024-03-01"},{"cvss_score":6.1,"headline":"Cross-site Scripting in Sidekiq","id":"CVE-2021-30151","kev_date_added":null,"published":"2021-04-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-25","vendors":["n/a"]},"summary":"An attacker can cause excessive polling requests leading to denial of service by manipulating localStorage values in the Sidekiq dashboard.","url":"https://insights.sbomify.com/CVE-2023-26141/"}