# CVE-2023-26141: sidekiq Denial of Service vulnerability

> An attacker can cause excessive polling requests leading to denial of service by manipulating localStorage values in the Sidekiq dashboard.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Sep 2023
- **Updated:** 25 Sep 2024
- **Also known as:** GHSA-3qc2-v3hp-6cv8

## What is CVE-2023-26141?

CVE-2023-26141 is a high-severity denial of service vulnerability in sidekiq, published on 14 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of the package sidekiq before 7.1.3 are vulnerable to Denial of Service (DoS) due to insufficient checks in the dashboard-charts.js file. An attacker can exploit this vulnerability by manipulating the localStorage value which will cause excessive polling requests.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2023-26141?

4 open source packages ship an affected version, including sidekiq. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sidekiq` | RubyGems | All versions | 6.5.10 |
| `sidekiq` | RubyGems | All versions | 6.5.10 |
| `sidekiq` | RubyGems | From 7.0.0 | 7.1.3 |
| `sidekiq` | RubyGems | From 7.0.0 | 7.1.3 |

Products: Contribsys Sidekiq.

## How do I fix CVE-2023-26141?

Upgrade sidekiq to a fixed version for your release line: 6.5.10 or 7.1.3.

## Is CVE-2023-26141 being exploited?

There is no known exploitation of CVE-2023-26141 in the wild and no public exploit code.

## Other vulnerabilities in sidekiq

- [CVE-2023-1892](https://insights.sbomify.com/CVE-2023-1892/): Cross-site Scripting (XSS) - Reflected in sidekiq/sidekiq (high 8.3)
- [CVE-2022-23837](https://insights.sbomify.com/CVE-2022-23837/): Denial of service in sidekiq (high 7.5)
- [CVE-2023-46950](https://insights.sbomify.com/CVE-2023-46950/): Cross-site scripting in n/a (medium 6.1)
- [CVE-2023-46951](https://insights.sbomify.com/CVE-2023-46951/): Cross-site scripting in n/a (medium 6.1)
- [CVE-2021-30151](https://insights.sbomify.com/CVE-2021-30151/): Cross-site Scripting in Sidekiq (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-26141 and fix it if it is affected.

What it is: CVE-2023-26141 is a high-severity denial of service vulnerability in sidekiq, published on 14 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-26141 in the wild and no public exploit code.

Affected packages and fixed versions:
- sidekiq (RubyGems): affected all versions; fixed in 6.5.10
- sidekiq (RubyGems): affected all versions; fixed in 6.5.10
- sidekiq (RubyGems): affected from 7.0.0; fixed in 7.1.3
- sidekiq (RubyGems): affected from 7.0.0; fixed in 7.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-26141/ (Markdown: https://insights.sbomify.com/CVE-2023-26141/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-26141
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-26141
- OSV: https://osv.dev/vulnerability/CVE-2023-26141

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-26141/
Summaries are generated and may contain mistakes; the official description above is the record.
