{"answers":{"affected":"2 open source packages ship an affected version, including blamer. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26143 exists.","fix":"Upgrade blamer to 1.0.4 or later.","what":"CVE-2023-26143 is a medium-severity command injection vulnerability in blamer, published on 19 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-26143 and fix it if it is affected.\n\nWhat it is: CVE-2023-26143 is a medium-severity command injection vulnerability in blamer, published on 19 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26143 exists.\n\nAffected packages and fixed versions:\n- blamer (npm): affected all versions; fixed in 1.0.4\n- blamer (npm): affected all versions; fixed in 1.0.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-26143/ (Markdown: https://insights.sbomify.com/CVE-2023-26143/index.md)","id":"CVE-2023-26143","markdown":"https://insights.sbomify.com/CVE-2023-26143/index.md","name":"CVE-2023-26143","record":{"aliases":["GHSA-6f9p-g466-f8v8"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js git library","requires_auth":"none","summary":"Attackers can execute arbitrary commands via argument injection in the blamer library's blameByFile API due to lack of input sanitization.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"blamer","vendor":"blamer_project"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L/E:P","version":"3.1"},"cwes":[{"id":"CWE-88","name":"Improper Neutralization of Argument Delimiters in a Command"}],"description":"Versions of the package blamer before 1.0.4 are vulnerable to Arbitrary Argument Injection via the blameByFile() API. The library does not sanitize for user input or validate the given file path conforms to a specific schema, nor does it properly pass command-line flags to the git binary using the double-dash POSIX characters (--) to communicate the end of options.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"blamer vulnerable to Arbitrary Argument Injection via the blameByFile() API","id":"CVE-2023-26143","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2023"},"n_packages":2,"n_references":3,"next":{"headline":"graphql Uncontrolled Resource Consumption vulnerability","id":"CVE-2023-26144"},"packages":[{"ecosystem":"npm","fixed":["1.0.4"],"introduced":["0"],"last_affected":[],"package":"blamer","purl":null,"source":"GHSA-6f9p-g466-f8v8"},{"ecosystem":"npm","fixed":["1.0.4"],"introduced":["0"],"last_affected":[],"package":"blamer","purl":"pkg:npm/blamer","source":"GHSA-6f9p-g466-f8v8"}],"prev":{"headline":"Other in Crow","id":"CVE-2023-26142"},"products":["blamer"],"published":"2023-09-19","related":[{"cvss_score":9.8,"headline":"Code injection in blamer","id":"CVE-2020-8137","kev_date_added":null,"published":"2020-03-20"},{"cvss_score":9.8,"headline":"Improper Neutralization of Special Elements used in an OS Command in Blamer","id":"CVE-2019-10807","kev_date_added":null,"published":"2020-03-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-25","vendors":["n/a"]},"summary":"Attackers can execute arbitrary commands via argument injection in the blamer library's blameByFile API due to lack of input sanitization.","url":"https://insights.sbomify.com/CVE-2023-26143/"}