# CVE-2023-26143: blamer vulnerable to Arbitrary Argument Injection via the blameByFile() API

> Attackers can execute arbitrary commands via argument injection in the blamer library's blameByFile API due to lack of input sanitization.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Sep 2023
- **Updated:** 25 Sep 2024
- **Also known as:** GHSA-6f9p-g466-f8v8

## What is CVE-2023-26143?

CVE-2023-26143 is a medium-severity command injection vulnerability in blamer, published on 19 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of the package blamer before 1.0.4 are vulnerable to Arbitrary Argument Injection via the blameByFile() API. The library does not sanitize for user input or validate the given file path conforms to a specific schema, nor does it properly pass command-line flags to the git binary using the double-dash POSIX characters (--) to communicate the end of options.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2023-26143?

2 open source packages ship an affected version, including blamer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `blamer` | npm | All versions | 1.0.4 |
| `blamer` | npm | All versions | 1.0.4 |

Products: Blamer Project Blamer.

## How do I fix CVE-2023-26143?

Upgrade blamer to 1.0.4 or later.

## Is CVE-2023-26143 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26143 exists.

## Other vulnerabilities in blamer

- [CVE-2020-8137](https://insights.sbomify.com/CVE-2020-8137/): Code injection in blamer (critical 9.8)
- [CVE-2019-10807](https://insights.sbomify.com/CVE-2019-10807/): Improper Neutralization of Special Elements used in an OS Command in Blamer (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-26143 and fix it if it is affected.

What it is: CVE-2023-26143 is a medium-severity command injection vulnerability in blamer, published on 19 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26143 exists.

Affected packages and fixed versions:
- blamer (npm): affected all versions; fixed in 1.0.4
- blamer (npm): affected all versions; fixed in 1.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-26143/ (Markdown: https://insights.sbomify.com/CVE-2023-26143/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-26143
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-26143
- OSV: https://osv.dev/vulnerability/CVE-2023-26143

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-26143/
Summaries are generated and may contain mistakes; the official description above is the record.
