CVE-2023-26144 graphql Uncontrolled Resource Consumption vulnerability

Medium 5.3 Published Updated

An attacker can degrade system performance by sending large queries to applications using the vulnerable GraphQL library.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-26144?

CVE-2023-26144 is a medium-severity denial of service vulnerability in graphql, published on 20 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Versions of the package graphql from 16.3.0 and before 16.8.1 are vulnerable to Denial of Service (DoS) due to insufficient checks in the OverlappingFieldsCanBeMergedRule.ts file when parsing large queries. This vulnerability allows an attacker to degrade system performance. **Note:** It was not proven that this vulnerability can crash the process.

Weakness: CWE-400

Which versions are affected by CVE-2023-26144?

2 open source packages ship an affected version, including graphql. It affects 1 product.

PackageAffectedFixed in
graphql npmFrom 16.3.016.8.1
graphql npmFrom 16.3.016.8.1

Products include Graphql Graphql.

How do I fix CVE-2023-26144?

Upgrade graphql to 16.8.1 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-26144 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26144 exists.

Public exploit code: 1 proofs of concept on GitHub.

Sources

Also known as DEBIAN-CVE-2023-26144, GHSA-9pv7-vfvm-6vr7, MINI-cm3w-v9qr-jfgj, ROOT-APP-NPM-CVE-2023-26144, UBUNTU-CVE-2023-26144.

Is CVE-2023-26144 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free