{"answers":{"affected":"2 open source packages ship an affected version, including graphql. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26144 exists.","fix":"Upgrade graphql to 16.8.1 or later.","what":"CVE-2023-26144 is a medium-severity denial of service vulnerability in graphql, published on 20 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-26144 and fix it if it is affected.\n\nWhat it is: CVE-2023-26144 is a medium-severity denial of service vulnerability in graphql, published on 20 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26144 exists.\n\nAffected packages and fixed versions:\n- graphql (npm): affected from 16.3.0; fixed in 16.8.1\n- graphql (npm): affected from 16.3.0; fixed in 16.8.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-26144/ (Markdown: https://insights.sbomify.com/CVE-2023-26144/index.md)","id":"CVE-2023-26144","markdown":"https://insights.sbomify.com/CVE-2023-26144/index.md","name":"CVE-2023-26144","record":{"aliases":["DEBIAN-CVE-2023-26144","GHSA-9pv7-vfvm-6vr7","MINI-cm3w-v9qr-jfgj","ROOT-APP-NPM-CVE-2023-26144","UBUNTU-CVE-2023-26144"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"GraphQL JavaScript library","requires_auth":"none","summary":"An attacker can degrade system performance by sending large queries to applications using the vulnerable GraphQL library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"graphql","vendor":"graphql"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L/E:P","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"Versions of the package graphql from 16.3.0 and before 16.8.1 are vulnerable to Denial of Service (DoS) due to insufficient checks in the OverlappingFieldsCanBeMergedRule.ts file when parsing large queries. This vulnerability allows an attacker to degrade system performance.\r\r**Note:** It was not proven that this vulnerability can crash the process.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":"2023-08-16","github_poc":1,"max_poc_stars":1,"metasploit":0,"nuclei":0,"refs":[{"date":"2023-08-16T11:44:22Z","kind":"github_poc","ref":"https://github.com/tadhglewis/apollo-koa-minimal","stars":1,"title":"GraphQL vulnerability disclosure: CVE-2023-26144"}],"tier":"weaponised"},"has_fix":true,"headline":"graphql Uncontrolled Resource Consumption vulnerability","id":"CVE-2023-26144","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":2,"n_references":5,"next":{"headline":"pydash Command Injection vulnerability","id":"CVE-2023-26145"},"packages":[{"ecosystem":"npm","fixed":["16.8.1"],"introduced":["16.3.0"],"last_affected":[],"package":"graphql","purl":null,"source":"GHSA-9pv7-vfvm-6vr7"},{"ecosystem":"npm","fixed":["16.8.1"],"introduced":["16.3.0"],"last_affected":[],"package":"graphql","purl":"pkg:npm/graphql","source":"GHSA-9pv7-vfvm-6vr7"}],"prev":{"headline":"blamer vulnerable to Arbitrary Argument Injection via the blameByFile() API","id":"CVE-2023-26143"},"products":["graphql"],"published":"2023-09-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-24","vendors":["n/a"]},"summary":"An attacker can degrade system performance by sending large queries to applications using the vulnerable GraphQL library.","url":"https://insights.sbomify.com/CVE-2023-26144/"}