# CVE-2023-26144: graphql Uncontrolled Resource Consumption vulnerability

> An attacker can degrade system performance by sending large queries to applications using the vulnerable GraphQL library.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Sep 2023
- **Updated:** 24 Sep 2024
- **Also known as:** DEBIAN-CVE-2023-26144, GHSA-9pv7-vfvm-6vr7, MINI-cm3w-v9qr-jfgj, ROOT-APP-NPM-CVE-2023-26144, UBUNTU-CVE-2023-26144

## What is CVE-2023-26144?

CVE-2023-26144 is a medium-severity denial of service vulnerability in graphql, published on 20 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of the package graphql from 16.3.0 and before 16.8.1 are vulnerable to Denial of Service (DoS) due to insufficient checks in the OverlappingFieldsCanBeMergedRule.ts file when parsing large queries. This vulnerability allows an attacker to degrade system performance.**Note:** It was not proven that this vulnerability can crash the process.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2023-26144?

2 open source packages ship an affected version, including graphql. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `graphql` | npm | From 16.3.0 | 16.8.1 |
| `graphql` | npm | From 16.3.0 | 16.8.1 |

Products: Graphql Graphql.

## How do I fix CVE-2023-26144?

Upgrade graphql to 16.8.1 or later.

## Is CVE-2023-26144 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26144 exists.

Public exploit code:

- GraphQL vulnerability disclosure: CVE-2023-26144 (github_poc): https://github.com/tadhglewis/apollo-koa-minimal

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-26144 and fix it if it is affected.

What it is: CVE-2023-26144 is a medium-severity denial of service vulnerability in graphql, published on 20 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26144 exists.

Affected packages and fixed versions:
- graphql (npm): affected from 16.3.0; fixed in 16.8.1
- graphql (npm): affected from 16.3.0; fixed in 16.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-26144/ (Markdown: https://insights.sbomify.com/CVE-2023-26144/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-26144
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-26144
- OSV: https://osv.dev/vulnerability/CVE-2023-26144

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-26144/
Summaries are generated and may contain mistakes; the official description above is the record.
