# CVE-2023-26150: asyncua Improper Authentication vulnerability

> Attackers can access the OPC UA Address Space without authentication or encryption due to missing session checks in the asyncua library.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Oct 2023
- **Updated:** 20 Sep 2024
- **Also known as:** GHSA-2894-qcqf-g23g, PYSEC-2023-189, UBUNTU-CVE-2023-26150

## What is CVE-2023-26150?

CVE-2023-26150 is a medium-severity authentication bypass vulnerability in asyncua, published on 3 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of the package asyncua before 0.9.96 are vulnerable to Improper Authentication such that it is possible to access Address Space without encryption and authentication.**Note:**This issue is a result of missing checks for services that require an active session.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2023-26150?

3 open source packages ship an affected version, including asyncua. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `asyncua` | PyPI | All versions | 0.9.96 |
| `asyncua` | PyPI | All versions | 0.9.96 |
| `asyncua` | PyPI | All versions | 0.9.96 |

Products: Freeopcua Opcua-Asyncio.

## How do I fix CVE-2023-26150?

Upgrade asyncua to 0.9.96 or later.

## Is CVE-2023-26150 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26150 exists.

## Other vulnerabilities in asyncua

- [CVE-2023-26151](https://insights.sbomify.com/CVE-2023-26151/): asyncua vulnerable to denial of service via infinite loop (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-26150 and fix it if it is affected.

What it is: CVE-2023-26150 is a medium-severity authentication bypass vulnerability in asyncua, published on 3 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26150 exists.

Affected packages and fixed versions:
- asyncua (PyPI): affected all versions; fixed in 0.9.96
- asyncua (PyPI): affected all versions; fixed in 0.9.96
- asyncua (PyPI): affected all versions; fixed in 0.9.96

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-26150/ (Markdown: https://insights.sbomify.com/CVE-2023-26150/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-26150
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-26150
- OSV: https://osv.dev/vulnerability/CVE-2023-26150

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-26150/
Summaries are generated and may contain mistakes; the official description above is the record.
