{"answers":{"affected":"3 open source packages ship an affected version, including asyncua. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26151 exists.","fix":"Upgrade asyncua to 0.9.96 or later.","what":"CVE-2023-26151 is a medium-severity denial of service vulnerability in asyncua, published on 3 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-26151 and fix it if it is affected.\n\nWhat it is: CVE-2023-26151 is a medium-severity denial of service vulnerability in asyncua, published on 3 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26151 exists.\n\nAffected packages and fixed versions:\n- asyncua (PyPI): affected all versions; fixed in 0.9.96\n- asyncua (PyPI): affected all versions; fixed in 0.9.96\n- asyncua (PyPI): affected all versions; fixed in 0.9.96\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-26151/ (Markdown: https://insights.sbomify.com/CVE-2023-26151/index.md)","id":"CVE-2023-26151","markdown":"https://insights.sbomify.com/CVE-2023-26151/index.md","name":"CVE-2023-26151","record":{"aliases":["GHSA-gfvq-mxw3-mfq3","PYSEC-2023-190","UBUNTU-CVE-2023-26151"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python OPC UA library","requires_auth":"none","summary":"An attacker can cause a denial of service by sending a malformed packet to the asyncua server, leading to an infinite loop and memory exhaustion.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"opcua-asyncio","vendor":"freeopcua"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L/E:P","version":"3.1"},"cwes":[{"id":"CWE-835","name":"Loop with Unreachable Exit Condition"},{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"Versions of the package asyncua before 0.9.96 are vulnerable to Denial of Service (DoS) such that an attacker can send a malformed packet and as a result, the server will enter into an infinite loop and consume excessive memory.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"asyncua vulnerable to denial of service via infinite loop","id":"CVE-2023-26151","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":3,"n_references":6,"next":{"headline":"static-server Path Traversal vulnerability","id":"CVE-2023-26152"},"packages":[{"ecosystem":"PyPI","fixed":["0.9.96"],"introduced":["0"],"last_affected":[],"package":"asyncua","purl":null,"source":"GHSA-gfvq-mxw3-mfq3"},{"ecosystem":"PyPI","fixed":["0.9.96"],"introduced":["0"],"last_affected":[],"package":"asyncua","purl":"pkg:pypi/asyncua","source":"GHSA-gfvq-mxw3-mfq3"},{"ecosystem":"PyPI","fixed":["0.9.96"],"introduced":["0"],"last_affected":[],"package":"asyncua","purl":"pkg:pypi/asyncua","source":"PYSEC-2023-190"}],"prev":{"headline":"asyncua Improper Authentication vulnerability","id":"CVE-2023-26150"},"products":["asyncua"],"published":"2023-10-03","related":[{"cvss_score":6.5,"headline":"asyncua Improper Authentication vulnerability","id":"CVE-2023-26150","kev_date_added":null,"published":"2023-10-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-20","vendors":["n/a"]},"summary":"An attacker can cause a denial of service by sending a malformed packet to the asyncua server, leading to an infinite loop and memory exhaustion.","url":"https://insights.sbomify.com/CVE-2023-26151/"}