{"answers":{"affected":"2 open source packages ship an affected version, including geokit-rails. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26153 exists.","fix":"Upgrade geokit-rails to 2.5.0 or later.","what":"CVE-2023-26153 is a high-severity unsafe deserialization vulnerability in geokit-rails, published on 6 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-26153 and fix it if it is affected.\n\nWhat it is: CVE-2023-26153 is a high-severity unsafe deserialization vulnerability in geokit-rails, published on 6 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26153 exists.\n\nAffected packages and fixed versions:\n- geokit-rails (RubyGems): affected all versions; fixed in 2.5.0\n- geokit-rails (RubyGems): affected all versions; fixed in 2.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-26153/ (Markdown: https://insights.sbomify.com/CVE-2023-26153/index.md)","id":"CVE-2023-26153","markdown":"https://insights.sbomify.com/CVE-2023-26153/index.md","name":"CVE-2023-26153","record":{"aliases":["GHSA-7xvc-v44j-46fh"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby geolocation library","requires_auth":"none","summary":"Remote attackers can execute arbitrary commands on the host system by sending a malicious YAML cookie to applications using this Ruby geolocation library.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"geokit-rails","vendor":"geokit"}],"cvss":{"score":8.3,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:L/E:P","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"},{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"Versions of the package geokit-rails before 2.5.0 are vulnerable to Command Injection due to unsafe deserialisation of YAML within the 'geo_location' cookie. This issue can be exploited remotely via a malicious cookie value.\r\r**Note:**\r\r An attacker can use this vulnerability to execute commands on the host system.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"geokit-rails Command Injection vulnerability","id":"CVE-2023-26153","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"deserialization","year":"2023"},"n_packages":2,"n_references":5,"next":{"headline":"pubnub Insufficient Entropy vulnerability","id":"CVE-2023-26154"},"packages":[{"ecosystem":"RubyGems","fixed":["2.5.0"],"introduced":["0"],"last_affected":[],"package":"geokit-rails","purl":null,"source":"GHSA-7xvc-v44j-46fh"},{"ecosystem":"RubyGems","fixed":["2.5.0"],"introduced":["0"],"last_affected":[],"package":"geokit-rails","purl":"pkg:gem/geokit-rails","source":"GHSA-7xvc-v44j-46fh"}],"prev":{"headline":"static-server Path Traversal vulnerability","id":"CVE-2023-26152"},"products":["geokit-rails"],"published":"2023-10-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-19","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary commands on the host system by sending a malicious YAML cookie to applications using this Ruby geolocation library.","url":"https://insights.sbomify.com/CVE-2023-26153/"}