{"answers":{"affected":"2 open source packages ship an affected version, including chromedriver. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26156 exists.","fix":"Upgrade chromedriver to 119.0.1 or later.","what":"CVE-2023-26156 is a medium-severity command injection vulnerability in chromedriver, published on 9 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-26156 and fix it if it is affected.\n\nWhat it is: CVE-2023-26156 is a medium-severity command injection vulnerability in chromedriver, published on 9 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26156 exists.\n\nAffected packages and fixed versions:\n- chromedriver (npm): affected all versions; fixed in 119.0.1\n- chromedriver (npm): affected all versions; fixed in 119.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-26156/ (Markdown: https://insights.sbomify.com/CVE-2023-26156/index.md)","id":"CVE-2023-26156","markdown":"https://insights.sbomify.com/CVE-2023-26156/index.md","name":"CVE-2023-26156","record":{"aliases":["GHSA-hm92-vgmw-qfmx"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"npm chromedriver library","requires_auth":"none","summary":"An attacker with local access can execute arbitrary commands by configuring the chromedriver path to a malicious binary.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"chromedriver","vendor":"chromedriver_project"}],"cvss":{"score":5.6,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L/E:P","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"Versions of the package chromedriver before 119.0.1 are vulnerable to Command Injection when setting the chromedriver.path to an arbitrary system binary. This could lead to unauthorized access and potentially malicious actions on the host system.\r\r**Note:**\r\rAn attacker must have access to the system running the vulnerable chromedriver library to exploit it. The success of exploitation also depends on the permissions and privileges of the process running chromedriver.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"chromedriver Command Injection vulnerability","id":"CVE-2023-26156","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2023"},"n_packages":2,"n_references":3,"next":{"headline":"Denial of service in libredwg","id":"CVE-2023-26157"},"packages":[{"ecosystem":"npm","fixed":["119.0.1"],"introduced":["0"],"last_affected":[],"package":"chromedriver","purl":null,"source":"GHSA-hm92-vgmw-qfmx"},{"ecosystem":"npm","fixed":["119.0.1"],"introduced":["0"],"last_affected":[],"package":"chromedriver","purl":"pkg:npm/chromedriver","source":"GHSA-hm92-vgmw-qfmx"}],"prev":{"headline":"node-qpdf vulnerable to command injection","id":"CVE-2023-26155"},"products":["chromedriver"],"published":"2023-11-09","related":[{"cvss_score":8.1,"headline":"chromedriver Downloads Resources over HTTP","id":"CVE-2016-10579","kev_date_added":null,"published":"2018-06-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-04","vendors":["n/a"]},"summary":"An attacker with local access can execute arbitrary commands by configuring the chromedriver path to a malicious binary.","url":"https://insights.sbomify.com/CVE-2023-26156/"}