# CVE-2023-26156: chromedriver Command Injection vulnerability

> An attacker with local access can execute arbitrary commands by configuring the chromedriver path to a malicious binary.

- **Severity:** Medium 5.6 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Nov 2023
- **Updated:** 4 Sep 2024
- **Also known as:** GHSA-hm92-vgmw-qfmx

## What is CVE-2023-26156?

CVE-2023-26156 is a medium-severity command injection vulnerability in chromedriver, published on 9 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of the package chromedriver before 119.0.1 are vulnerable to Command Injection when setting the chromedriver.path to an arbitrary system binary. This could lead to unauthorized access and potentially malicious actions on the host system.**Note:**An attacker must have access to the system running the vulnerable chromedriver library to exploit it. The success of exploitation also depends on the permissions and privileges of the process running chromedriver.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2023-26156?

2 open source packages ship an affected version, including chromedriver. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `chromedriver` | npm | All versions | 119.0.1 |
| `chromedriver` | npm | All versions | 119.0.1 |

Products: Chromedriver Project Chromedriver.

## How do I fix CVE-2023-26156?

Upgrade chromedriver to 119.0.1 or later.

## Is CVE-2023-26156 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26156 exists.

## Other vulnerabilities in chromedriver

- [CVE-2016-10579](https://insights.sbomify.com/CVE-2016-10579/): chromedriver Downloads Resources over HTTP (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-26156 and fix it if it is affected.

What it is: CVE-2023-26156 is a medium-severity command injection vulnerability in chromedriver, published on 9 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26156 exists.

Affected packages and fixed versions:
- chromedriver (npm): affected all versions; fixed in 119.0.1
- chromedriver (npm): affected all versions; fixed in 119.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-26156/ (Markdown: https://insights.sbomify.com/CVE-2023-26156/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-26156
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-26156
- OSV: https://osv.dev/vulnerability/CVE-2023-26156

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-26156/
Summaries are generated and may contain mistakes; the official description above is the record.
