{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-26157 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2023-26157 is a medium-severity denial of service vulnerability in Gnu Libredwg, published on 2 Jan 2024. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-26157 and fix it if it is affected.\n\nWhat it is: CVE-2023-26157 is a medium-severity denial of service vulnerability in Gnu Libredwg, published on 2 Jan 2024. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-26157 in the wild and no public exploit code.\n\nAffected product: Gnu Libredwg. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-26157/ (Markdown: https://insights.sbomify.com/CVE-2023-26157/index.md)","id":"CVE-2023-26157","markdown":"https://insights.sbomify.com/CVE-2023-26157/index.md","name":"CVE-2023-26157","record":{"aliases":["GHSA-5rxp-9658-h93v","openSUSE-SU-2024:0147-1","openSUSE-SU-2024:13544-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"DWG file library","requires_auth":"low_privilege","summary":"An out-of-bounds read in libredwg allows attackers to cause a denial of service via crafted DWG files.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"libredwg","vendor":"gnu"}],"cvss":{"score":5.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H/E:P","version":"3.1"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"},{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"Versions of the package libredwg before 0.12.5.6384 are vulnerable to Denial of Service (DoS) due to an out-of-bounds read involving section-\u003enum_pages in decode_r2007.c.","ecosystems":["SUSE:Package Hub 15 SP5","openSUSE:Leap 15.5","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in libredwg","id":"CVE-2023-26157","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"gnu:libredwg","products":["gnu:libredwg"],"type":"denial_of_service","year":"2023"},"n_packages":3,"n_references":3,"next":{"headline":"mockjs vulnerable to Prototype Pollution via the Util.extend function","id":"CVE-2023-26158"},"packages":[{"ecosystem":"SUSE:Package Hub 15 SP5","fixed":["0.12.5.6924-bp155.3.6.1"],"introduced":["0"],"last_affected":[],"package":"libredwg","purl":"pkg:rpm/suse/libredwg\u0026distro=SUSE%20Package%20Hub%2015%20SP5","source":"openSUSE-SU-2024:0147-1"},{"ecosystem":"openSUSE:Leap 15.5","fixed":["0.12.5.6924-bp155.3.6.1"],"introduced":["0"],"last_affected":[],"package":"libredwg","purl":"pkg:rpm/opensuse/libredwg\u0026distro=openSUSE%20Leap%2015.5","source":"openSUSE-SU-2024:0147-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.12.5.6924-1.1"],"introduced":["0"],"last_affected":[],"package":"libredwg","purl":"pkg:rpm/opensuse/libredwg\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:13544-1"}],"prev":{"headline":"chromedriver Command Injection vulnerability","id":"CVE-2023-26156"},"products":["libredwg"],"published":"2024-01-02","related":[{"cvss_score":9.8,"headline":"Use after free in n/a","id":"CVE-2022-35164","kev_date_added":null,"published":"2022-08-18"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2021-28237","kev_date_added":null,"published":"2021-12-02"},{"cvss_score":9.8,"headline":"Null dereference in n/a","id":"CVE-2019-20914","kev_date_added":null,"published":"2020-07-16"},{"cvss_score":9.1,"headline":"Memory corruption in n/a","id":"CVE-2019-9774","kev_date_added":null,"published":"2019-03-14"},{"cvss_score":9.1,"headline":"Information disclosure in n/a","id":"CVE-2019-9775","kev_date_added":null,"published":"2019-03-14"},{"cvss_score":8.8,"headline":"Memory corruption in n/a","id":"CVE-2023-36271","kev_date_added":null,"published":"2023-06-23"},{"cvss_score":8.8,"headline":"Memory corruption in n/a","id":"CVE-2023-36272","kev_date_added":null,"published":"2023-06-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-11-14","vendors":["n/a"]},"summary":"An out-of-bounds read in libredwg allows attackers to cause a denial of service via crafted DWG files.","url":"https://insights.sbomify.com/CVE-2023-26157/"}