# CVE-2023-26159: Follow Redirects improperly handles URLs in the url.parse() function

> Attackers can manipulate URL parsing to redirect traffic to malicious sites, enabling phishing or information disclosure in applications using the library.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jan 2024
- **Updated:** 3 Nov 2025
- **Also known as:** AZL-32314, AZL-38299, AZL-43636, AZL-45348, CLSA-2026-1776818197, DEBIAN-CVE-2023-26159, GHSA-jchw-25xp-jwwc, UBUNTU-CVE-2023-26159

## What is CVE-2023-26159?

CVE-2023-26159 is a high-severity vulnerability in follow-redirects, published on 2 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of the package follow-redirects before 1.15.4 are vulnerable to Improper Input Validation due to the improper handling of URLs by the url.parse() function. When new URL() throws an error, it can be manipulated to misinterpret the hostname. An attacker could exploit this weakness to redirect traffic to a malicious site, potentially leading to information disclosure, phishing attacks, or other security breaches.

Weakness: CWE-601 (URL Redirection to Untrusted Site), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-26159?

2 open source packages ship an affected version, including follow-redirects. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `follow-redirects` | npm | All versions | 1.15.4 |
| `follow-redirects` | npm | All versions | 1.15.4 |

Products: Follow-Redirects Follow Redirects.

## How do I fix CVE-2023-26159?

Upgrade follow-redirects to 1.15.4 or later.

## Is CVE-2023-26159 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26159 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-26159 and fix it if it is affected.

What it is: CVE-2023-26159 is a high-severity vulnerability in follow-redirects, published on 2 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26159 exists.

Affected packages and fixed versions:
- follow-redirects (npm): affected all versions; fixed in 1.15.4
- follow-redirects (npm): affected all versions; fixed in 1.15.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-26159/ (Markdown: https://insights.sbomify.com/CVE-2023-26159/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-26159
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-26159
- OSV: https://osv.dev/vulnerability/CVE-2023-26159

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-26159/
Summaries are generated and may contain mistakes; the official description above is the record.
