# CVE-2023-26269: Apache James server: Privilege escalation through unauthenticated JMX

> A malicious local user can escalate privileges via the unauthenticated JMX management service in Apache James server.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Apr 2023
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-w7r6-v4j7-h94w

## What is CVE-2023-26269?

CVE-2023-26269 is a high-severity missing authorization vulnerability in Apache James server, published on 3 Apr 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Apache James server version 3.7.3 and earlier provides a JMX management service without authentication by default. This allows privilege escalation by a 
malicious local user.

Administrators are advised to disable JMX, or set up a JMX password.

Note that version 3.7.4 onward will set up a JMX password automatically for Guice users.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2023-26269?

2 open source packages ship an affected version, including org.apache.james:javax-mail-extension. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.james:javax-mail-extension` | Maven | All versions | 3.7.4 |
| `org.apache.james:javax-mail-extension` | Maven | All versions | 3.7.4 |

Products: Apache James.

## How do I fix CVE-2023-26269?

Upgrade org.apache.james:javax-mail-extension to 3.7.4 or later.

## Is CVE-2023-26269 being exploited?

There is no known exploitation of CVE-2023-26269 in the wild and no public exploit code.

Public exploit code:

- CVE-2023-26269: Misconfigured JMX in Apache James (github_poc): https://github.com/mbadanoiu/CVE-2023-26269

## Other vulnerabilities in Apache James server

- [CVE-2023-51518](https://insights.sbomify.com/CVE-2023-51518/): Apache James server: Privilege escalation via JMX pre-authentication deserialisation (critical 9.8)
- [CVE-2019-0228](https://insights.sbomify.com/CVE-2019-0228/): Vulnerability that affects org.apache.pdfbox:pdfbox (critical 9.8)
- [CVE-2021-40525](https://insights.sbomify.com/CVE-2021-40525/): Sieve file storage vulnerable to path traversal attacks (critical 9.1)
- [CVE-2006-2806](https://insights.sbomify.com/CVE-2006-2806/): Denial of service in n/a (high 7.8)
- [CVE-2022-28220](https://insights.sbomify.com/CVE-2022-28220/): STARTTLS command injection in Apache JAMES (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-26269 and fix it if it is affected.

What it is: CVE-2023-26269 is a high-severity missing authorization vulnerability in Apache James server, published on 3 Apr 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-26269 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.james:javax-mail-extension (Maven): affected all versions; fixed in 3.7.4
- org.apache.james:javax-mail-extension (Maven): affected all versions; fixed in 3.7.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-26269/ (Markdown: https://insights.sbomify.com/CVE-2023-26269/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-26269
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-26269
- OSV: https://osv.dev/vulnerability/CVE-2023-26269

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-26269/
Summaries are generated and may contain mistakes; the official description above is the record.
