{"answers":{"affected":"3 open source packages ship an affected version, including markdown-it-py. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-26302 in the wild and no public exploit code.","fix":"Upgrade markdown-it-py to 2.2.0 or later.","what":"CVE-2023-26302 is a low-severity denial of service vulnerability in Executable Books markdown-it-py, published on 22 Feb 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-26302 and fix it if it is affected.\n\nWhat it is: CVE-2023-26302 is a low-severity denial of service vulnerability in Executable Books markdown-it-py, published on 22 Feb 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-26302 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- markdown-it-py (PyPI): affected all versions; fixed in 2.2.0\n- markdown-it-py (PyPI): affected all versions; fixed in 2.2.0\n- markdown-it-py (PyPI): affected all versions; fixed in 2.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-26302/ (Markdown: https://insights.sbomify.com/CVE-2023-26302/index.md)","id":"CVE-2023-26302","markdown":"https://insights.sbomify.com/CVE-2023-26302/index.md","name":"CVE-2023-26302","record":{"aliases":["DEBIAN-CVE-2023-26302","GHSA-jrwr-5x3p-hvc3","PYSEC-2023-23","ROOT-APP-PYPI-CVE-2023-26302","UBUNTU-CVE-2023-26302"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Python markdown library","requires_auth":"low_privilege","summary":"An attacker can cause a denial of service in the markdown-it-py CLI by providing invalid UTF-8 characters as input.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"canonical","cpe":[{"product":"markdown-it-py","vendor":"executablebooks"}],"cvss":{"score":3.3,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-173","name":"Improper Handling of Alternate Encoding"}],"description":"Denial of service could be caused to the command line interface of markdown-it-py, before v2.2.0, if an attacker was allowed to use invalid UTF-8 characters as input.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"markdown-it-py CLI crash on invalid UTF-8 characters","id":"CVE-2023-26302","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":3,"n_references":1,"next":{"headline":"markdown-it-py crash on null assertions","id":"CVE-2023-26303"},"packages":[{"ecosystem":"PyPI","fixed":["2.2.0"],"introduced":["0"],"last_affected":[],"package":"markdown-it-py","purl":null,"source":"GHSA-jrwr-5x3p-hvc3"},{"ecosystem":"PyPI","fixed":["2.2.0"],"introduced":["0"],"last_affected":[],"package":"markdown-it-py","purl":"pkg:pypi/markdown-it-py","source":"GHSA-jrwr-5x3p-hvc3"},{"ecosystem":"PyPI","fixed":["2.2.0"],"introduced":["0"],"last_affected":[],"package":"markdown-it-py","purl":"pkg:pypi/markdown-it-py","source":"PYSEC-2023-23"}],"prev":{"headline":"Missing authorization in HP LaserJet Pro","id":"CVE-2023-26301"},"products":["markdown-it-py"],"published":"2023-02-22","related":[{"cvss_score":3.3,"headline":"markdown-it-py crash on null assertions","id":"CVE-2023-26303","kev_date_added":null,"published":"2023-02-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-11","vendors":["Executable Books"]},"summary":"An attacker can cause a denial of service in the markdown-it-py CLI by providing invalid UTF-8 characters as input.","url":"https://insights.sbomify.com/CVE-2023-26302/"}