CVE-2023-2631 CSRF vulnerability and missing permission checks in Code Dx Plugin
Medium 4.3
Published
Updated
Check this codebase for CVE-2023-2631 and fix it if it is affected.
What it is: CVE-2023-2631 is a medium-severity vulnerability in Jenkins Code Dx Plugin, published on 16 May 2023.
Exploitation: There is no known exploitation of CVE-2023-2631 in the wild and no public exploit code.
Affected packages and fixed versions:
- org.jenkins-ci.plugins:codedx (Maven): affected all versions; fixed in 4.0.0
- org.jenkins-ci.plugins:codedx (Maven): affected all versions; fixed in 4.0.0
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/CVE-2023-2631/ (Markdown: https://insights.sbomify.com/CVE-2023-2631/index.md)
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2023-2631?
CVE-2023-2631 is a medium-severity vulnerability in Jenkins Code Dx Plugin, published on 16 May 2023.
Official description
A missing permission check in Jenkins Code Dx Plugin 3.1.0 and earlier allows attackers with Overall/Read permission to connect to an attacker-specified URL.
Weakness: CWE-352
Which versions are affected by CVE-2023-2631?
2 open source packages ship an affected version, including org.jenkins-ci.plugins:codedx. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.jenkins-ci.plugins:codedx Maven | All versions | 4.0.0 |
org.jenkins-ci.plugins:codedx Maven | All versions | 4.0.0 |
Products include Jenkins Code Dx.
How do I fix CVE-2023-2631?
Upgrade org.jenkins-ci.plugins:codedx to 4.0.0 or later.
Is CVE-2023-2631 being exploited?
There is no known exploitation of CVE-2023-2631 in the wild and no public exploit code.
Other vulnerabilities in Jenkins Code Dx Plugin
Sources
Also known as GHSA-mjmf-7wjw-f5xx.