CVE-2023-26364 Denial of Service of regular expression in package @adobe/css-tools
Attackers can cause a denial of service by sending specially crafted CSS input to applications using the @adobe/css-tools library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-26364?
CVE-2023-26364 is a medium-severity denial of service vulnerability in Adobe Not a product, published on 17 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
@adobe/css-tools version 4.3.0 and earlier are affected by an Improper Input Validation vulnerability that could result in a minor denial of service while attempting to parse CSS. Exploitation of this issue does not require user interaction or privileges.
Weakness: CWE-20
Which versions are affected by CVE-2023-26364?
2 open source packages ship an affected version, including @adobe/css-tools. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
@adobe/css-tools npm | All versions | 4.3.1 |
@adobe/css-tools npm | All versions | 4.3.1 |
Linux distribution packages (3)
cockpit-wicked SUSE:Linux Enterprise Micro 5.4 | All versions | 4.5-150400.3.3.1 |
cockpit-wicked SUSE:Linux Enterprise Micro 5.5 | All versions | 5~git8.c06c55b-150500.3.3.1 |
cockpit-wicked SUSE:Linux Enterprise Micro 5.5 | All versions | 5~git8.c06c55b-150500.3.3.1 |
Products include Adobe Css-Tools.
How do I fix CVE-2023-26364?
Upgrade @adobe/css-tools to 4.3.1 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2023-26364 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26364 exists.
Other vulnerabilities in Adobe Not a product
Sources
Also known as GHSA-hpx4-r86g-5jrg, SUSE-SU-2024:1415-1, SUSE-SU-2024:1415-2, SUSE-SU-2024:1416-1.