{"answers":{"affected":"2 open source packages ship an affected version, including @adobe/css-tools. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26364 exists.","fix":"Upgrade @adobe/css-tools to 4.3.1 or later.","what":"CVE-2023-26364 is a medium-severity denial of service vulnerability in Adobe Not a product, published on 17 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-26364 and fix it if it is affected.\n\nWhat it is: CVE-2023-26364 is a medium-severity denial of service vulnerability in Adobe Not a product, published on 17 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26364 exists.\n\nAffected packages and fixed versions:\n- @adobe/css-tools (npm): affected all versions; fixed in 4.3.1\n- @adobe/css-tools (npm): affected all versions; fixed in 4.3.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-26364/ (Markdown: https://insights.sbomify.com/CVE-2023-26364/index.md)","id":"CVE-2023-26364","markdown":"https://insights.sbomify.com/CVE-2023-26364/index.md","name":"CVE-2023-26364","record":{"aliases":["GHSA-hpx4-r86g-5jrg","SUSE-SU-2024:1415-1","SUSE-SU-2024:1415-2","SUSE-SU-2024:1416-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"CSS parsing library","requires_auth":"none","summary":"Attackers can cause a denial of service by sending specially crafted CSS input to applications using the @adobe/css-tools library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"adobe","cpe":[{"product":"css-tools","vendor":"adobe"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"@adobe/css-tools version 4.3.0 and earlier are affected by an Improper Input Validation vulnerability that could result in a minor denial of service while attempting to parse CSS. Exploitation of this issue does not require user interaction or privileges.","ecosystems":["SUSE:Linux Enterprise Micro 5.4","SUSE:Linux Enterprise Micro 5.5","npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Denial of Service of regular expression in package @adobe/css-tools","id":"CVE-2023-26364","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":5,"n_references":1,"next":{"headline":"Validate Your Inputs | Server-Side Request Forgery (SSRF) (CWE-918)","id":"CVE-2023-26366"},"packages":[{"ecosystem":"npm","fixed":["4.3.1"],"introduced":["0"],"last_affected":[],"package":"@adobe/css-tools","purl":null,"source":"GHSA-hpx4-r86g-5jrg"},{"ecosystem":"npm","fixed":["4.3.1"],"introduced":["0"],"last_affected":[],"package":"@adobe/css-tools","purl":"pkg:npm/%40adobe/css-tools","source":"GHSA-hpx4-r86g-5jrg"},{"ecosystem":"SUSE:Linux Enterprise Micro 5.4","fixed":["4.5-150400.3.3.1"],"introduced":["0"],"last_affected":[],"package":"cockpit-wicked","purl":"pkg:rpm/suse/cockpit-wicked\u0026distro=SUSE%20Linux%20Enterprise%20Micro%205.4","source":"SUSE-SU-2024:1416-1"},{"ecosystem":"SUSE:Linux Enterprise Micro 5.5","fixed":["5~git8.c06c55b-150500.3.3.1"],"introduced":["0"],"last_affected":[],"package":"cockpit-wicked","purl":"pkg:rpm/suse/cockpit-wicked\u0026distro=SUSE%20Linux%20Enterprise%20Micro%205.5","source":"SUSE-SU-2024:1415-1"},{"ecosystem":"SUSE:Linux Enterprise Micro 5.5","fixed":["5~git8.c06c55b-150500.3.3.1"],"introduced":["0"],"last_affected":[],"package":"cockpit-wicked","purl":"pkg:rpm/suse/cockpit-wicked\u0026distro=SUSE%20Linux%20Enterprise%20Micro%205.5","source":"SUSE-SU-2024:1415-2"}],"prev":{"headline":"Adobe ColdFusion Directory Traversal Arbitrary file system read Vulnerability","id":"CVE-2023-26361"},"products":["Not a product"],"published":"2023-11-17","related":[{"cvss_score":5.3,"headline":"Denial of Service of regular expression in package @adobe/css-tools","id":"CVE-2023-48631","kev_date_added":null,"published":"2023-12-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-29","vendors":["Adobe"]},"summary":"Attackers can cause a denial of service by sending specially crafted CSS input to applications using the @adobe/css-tools library.","url":"https://insights.sbomify.com/CVE-2023-26364/"}