# CVE-2023-26364: Denial of Service of regular expression in package @adobe/css-tools

> Attackers can cause a denial of service by sending specially crafted CSS input to applications using the @adobe/css-tools library.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Nov 2023
- **Updated:** 29 Aug 2024
- **Also known as:** GHSA-hpx4-r86g-5jrg, SUSE-SU-2024:1415-1, SUSE-SU-2024:1415-2, SUSE-SU-2024:1416-1

## What is CVE-2023-26364?

CVE-2023-26364 is a medium-severity denial of service vulnerability in Adobe Not a product, published on 17 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

@adobe/css-tools version 4.3.0 and earlier are affected by an Improper Input Validation vulnerability that could result in a minor denial of service while attempting to parse CSS. Exploitation of this issue does not require user interaction or privileges.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-26364?

2 open source packages ship an affected version, including @adobe/css-tools. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@adobe/css-tools` | npm | All versions | 4.3.1 |
| `@adobe/css-tools` | npm | All versions | 4.3.1 |
| `cockpit-wicked` | SUSE:Linux Enterprise Micro 5.4 | All versions | 4.5-150400.3.3.1 |
| `cockpit-wicked` | SUSE:Linux Enterprise Micro 5.5 | All versions | 5~git8.c06c55b-150500.3.3.1 |
| `cockpit-wicked` | SUSE:Linux Enterprise Micro 5.5 | All versions | 5~git8.c06c55b-150500.3.3.1 |

Products: Adobe Css-Tools.

## How do I fix CVE-2023-26364?

Upgrade @adobe/css-tools to 4.3.1 or later.

## Is CVE-2023-26364 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26364 exists.

## Other vulnerabilities in Adobe Not a product

- [CVE-2023-48631](https://insights.sbomify.com/CVE-2023-48631/): Denial of Service of regular expression in package @adobe/css-tools (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-26364 and fix it if it is affected.

What it is: CVE-2023-26364 is a medium-severity denial of service vulnerability in Adobe Not a product, published on 17 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26364 exists.

Affected packages and fixed versions:
- @adobe/css-tools (npm): affected all versions; fixed in 4.3.1
- @adobe/css-tools (npm): affected all versions; fixed in 4.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-26364/ (Markdown: https://insights.sbomify.com/CVE-2023-26364/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-26364
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-26364
- OSV: https://osv.dev/vulnerability/CVE-2023-26364

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-26364/
Summaries are generated and may contain mistakes; the official description above is the record.
