# CVE-2023-26464: Apache Log4j 1.x (EOL) allows DoS in Chainsaw and SocketAppender

> Attackers can cause Denial of Service in Log4j 1.x by triggering memory exhaustion via specially crafted objects in Chainsaw or SocketAppender components.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Mar 2023
- **Updated:** 13 Feb 2025
- **Also known as:** CLSA-2025-1754352206, GHSA-vp98-w2p3-mv35, MINI-mf8p-gm85-4wjc, MINI-w8mq-62jw-ggrv, ROOT-APP-MAVEN-CVE-2023-26464, UBUNTU-CVE-2023-26464

## What is CVE-2023-26464?

CVE-2023-26464 is a high-severity denial of service vulnerability in Apache Log4j, published on 10 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

** UNSUPPORTED WHEN ASSIGNED **

When using the Chainsaw or SocketAppender components with Log4j 1.x on JRE less than 1.7, an attacker that manages to cause a logging entry involving a specially-crafted (ie, deeply nested) 
hashmap or hashtable (depending on which logging component is in use) to be processed could exhaust the available memory in the virtual machine and achieve Denial of Service when the object is deserialized.

This issue affects Apache Log4j before 2. Affected users are recommended to update to Log4j 2.x.

NOTE: This vulnerability only affects products that are no longer supported by the maintainer.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2023-26464?

4 open source packages ship an affected version, including org.apache.logging.log4j:log4j-core and log4j:log4j. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.logging.log4j:log4j-core` | Maven | From 1.0.4 | 2.0 |
| `org.apache.logging.log4j:log4j-core` | Maven | From 1.0.4 | 2.0 |
| `log4j:log4j` | Maven | From 1.0.4 | 2.0 |
| `log4j:log4j` | Maven | From 1.0.4 | 2.0 |

Products: Apache Log4j.

## How do I fix CVE-2023-26464?

Upgrade org.apache.logging.log4j:log4j-core to 2.0 or later.

## Is CVE-2023-26464 being exploited?

There is no known exploitation of CVE-2023-26464 in the wild and no public exploit code.

## Other vulnerabilities in Apache Log4j

- [CVE-2021-44228](https://insights.sbomify.com/CVE-2021-44228/): Apache Log4j2 Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-45046](https://insights.sbomify.com/CVE-2021-45046/): Apache Log4j2 Deserialization of Untrusted Data (critical 9.0, exploited in the wild)
- [CVE-2022-23305](https://insights.sbomify.com/CVE-2022-23305/): SQL injection in JDBC Appender in Apache Log4j V1 (critical 9.8)
- [CVE-2017-5645](https://insights.sbomify.com/CVE-2017-5645/): Deserialization of Untrusted Data in Log4j (critical 9.8)
- [CVE-2022-23302](https://insights.sbomify.com/CVE-2022-23302/): Deserialization of untrusted data in JMSSink in Apache Log4j 1.x (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-26464 and fix it if it is affected.

What it is: CVE-2023-26464 is a high-severity denial of service vulnerability in Apache Log4j, published on 10 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-26464 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.logging.log4j:log4j-core (Maven): affected from 1.0.4; fixed in 2.0
- org.apache.logging.log4j:log4j-core (Maven): affected from 1.0.4; fixed in 2.0
- log4j:log4j (Maven): affected from 1.0.4; fixed in 2.0
- log4j:log4j (Maven): affected from 1.0.4; fixed in 2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-26464/ (Markdown: https://insights.sbomify.com/CVE-2023-26464/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-26464
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-26464
- OSV: https://osv.dev/vulnerability/CVE-2023-26464

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-26464/
Summaries are generated and may contain mistakes; the official description above is the record.
