# CVE-2023-26473: XWiki Platform allows unprivileged users to make arbitrary select queries using DatabaseListProperty and suggest.vm

> Unprivileged users with edit rights can execute arbitrary database select queries to access sensitive data in XWiki Platform.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Mar 2023
- **Updated:** 5 Mar 2025
- **Also known as:** GHSA-vpx4-7rfp-h545

## What is CVE-2023-26473?

CVE-2023-26473 is a medium-severity missing authorization vulnerability in Xwiki Xwiki, published on 2 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform. Starting in version 1.3-rc-1, any user with edit right can execute arbitrary database select and access data stored in the database. The problem has been patched in XWiki 13.10.11, 14.4.7, and 14.10. There is no workaround for this vulnerability other than upgrading.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2023-26473?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-web. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-web` | Maven | From 1.3-rc-1 | 13.10.11 |
| `org.xwiki.platform:xwiki-platform-web` | Maven | From 1.3-rc-1 | 13.10.11 |
| `org.xwiki.platform:xwiki-platform-web` | Maven | From 14.0 | 14.4.7 |
| `org.xwiki.platform:xwiki-platform-web` | Maven | From 14.0 | 14.4.7 |
| `org.xwiki.platform:xwiki-platform-web` | Maven | From 14.5 | 14.10 |
| `org.xwiki.platform:xwiki-platform-web` | Maven | From 14.5 | 14.10 |

Products: Xwiki Xwiki.

## How do I fix CVE-2023-26473?

Upgrade org.xwiki.platform:xwiki-platform-web to a fixed version for your release line: 13.10.11, 14.4.7 or 14.10.

## Is CVE-2023-26473 being exploited?

There is no known exploitation of CVE-2023-26473 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-26473 and fix it if it is affected.

What it is: CVE-2023-26473 is a medium-severity missing authorization vulnerability in Xwiki Xwiki, published on 2 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-26473 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-web (Maven): affected from 1.3-rc-1; fixed in 13.10.11
- org.xwiki.platform:xwiki-platform-web (Maven): affected from 1.3-rc-1; fixed in 13.10.11
- org.xwiki.platform:xwiki-platform-web (Maven): affected from 14.0; fixed in 14.4.7
- org.xwiki.platform:xwiki-platform-web (Maven): affected from 14.0; fixed in 14.4.7
- org.xwiki.platform:xwiki-platform-web (Maven): affected from 14.5; fixed in 14.10
- org.xwiki.platform:xwiki-platform-web (Maven): affected from 14.5; fixed in 14.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-26473/ (Markdown: https://insights.sbomify.com/CVE-2023-26473/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-26473
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-26473
- OSV: https://osv.dev/vulnerability/CVE-2023-26473

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-26473/
Summaries are generated and may contain mistakes; the official description above is the record.
