# CVE-2023-26477: org.xwiki.platform:xwiki-platform-flamingo-theme-ui Eval Injection vulnerability

> Attackers can inject arbitrary Groovy, Python, or Velocity scripts via the newThemeName URL parameter in XWiki Platform, leading to remote code execution.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Mar 2023
- **Updated:** 5 Mar 2025
- **Also known as:** GHSA-x2qm-r4wx-8gpg

## What is CVE-2023-26477?

CVE-2023-26477 is a critical code injection vulnerability in Xwiki Xwiki, published on 2 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform. Starting in versions 6.3-rc-1 and 6.2.4, it's possible to inject arbitrary wiki syntax including Groovy, Python and Velocity script macros via the `newThemeName` request parameter (URL parameter), in combination with additional parameters. This has been patched in the supported versions 13.10.10, 14.9-rc-1, and 14.4.6. As a workaround, it is possible to edit `FlamingoThemesCode.WebHomeSheet` and manually perform the changes from the patch fixing the issue.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-95 (Improper Neutralization of Directives in Dynamically Evaluated Code)

## Which versions are affected by CVE-2023-26477?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-flamingo-theme-ui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-flamingo-theme-ui` | Maven | From 14.0 | 14.4.6 |
| `org.xwiki.platform:xwiki-platform-flamingo-theme-ui` | Maven | From 14.0 | 14.4.6 |
| `org.xwiki.platform:xwiki-platform-flamingo-theme-ui` | Maven | From 14.5 | 14.9-rc-1 |
| `org.xwiki.platform:xwiki-platform-flamingo-theme-ui` | Maven | From 14.5 | 14.9-rc-1 |
| `org.xwiki.platform:xwiki-platform-flamingo-theme-ui` | Maven | From 6.2.4 | 13.10.10 |
| `org.xwiki.platform:xwiki-platform-flamingo-theme-ui` | Maven | From 6.2.4 | 13.10.10 |

Products: Xwiki Xwiki.

## How do I fix CVE-2023-26477?

Upgrade org.xwiki.platform:xwiki-platform-flamingo-theme-ui to a fixed version for your release line: 14.4.6, 14.9-rc-1 or 13.10.10.

## Is CVE-2023-26477 being exploited?

There is no known exploitation of CVE-2023-26477 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-26477 and fix it if it is affected.

What it is: CVE-2023-26477 is a critical code injection vulnerability in Xwiki Xwiki, published on 2 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-26477 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-flamingo-theme-ui (Maven): affected from 14.0; fixed in 14.4.6
- org.xwiki.platform:xwiki-platform-flamingo-theme-ui (Maven): affected from 14.0; fixed in 14.4.6
- org.xwiki.platform:xwiki-platform-flamingo-theme-ui (Maven): affected from 14.5; fixed in 14.9-rc-1
- org.xwiki.platform:xwiki-platform-flamingo-theme-ui (Maven): affected from 14.5; fixed in 14.9-rc-1
- org.xwiki.platform:xwiki-platform-flamingo-theme-ui (Maven): affected from 6.2.4; fixed in 13.10.10
- org.xwiki.platform:xwiki-platform-flamingo-theme-ui (Maven): affected from 6.2.4; fixed in 13.10.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-26477/ (Markdown: https://insights.sbomify.com/CVE-2023-26477/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-26477
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-26477
- OSV: https://osv.dev/vulnerability/CVE-2023-26477

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-26477/
Summaries are generated and may contain mistakes; the official description above is the record.
