# CVE-2023-26478: org.xwiki.platform:xwiki-platform-store-filesystem-oldcore has Exposed Dangerous Method or Function

> Attackers can bypass programming rights checks to execute dangerous operations via exposed attachment methods in XWiki Platform.

- **Severity:** Medium 6.6 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Mar 2023
- **Updated:** 5 Mar 2025
- **Also known as:** GHSA-8692-g6g9-gm5p

## What is CVE-2023-26478?

CVE-2023-26478 is a medium-severity missing authorization vulnerability in Xwiki Xwiki, published on 2 Mar 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform. Starting in version 14.3-rc-1, `org.xwiki.store.script.TemporaryAttachmentsScriptService#uploadTemporaryAttachment` returns an instance of `com.xpn.xwiki.doc.XWikiAttachment`. This class is not supported to be exposed to users without the `programing` right.
`com.xpn.xwiki.api.Attachment` should be used instead and takes case of checking the user's rights before performing dangerous operations. This has been patched in versions 14.9-rc-1 and 14.4.6. There are no known workarounds for this issue.

Weakness: CWE-749 (Exposed Dangerous Method or Function)

## Which versions are affected by CVE-2023-26478?

4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-store-filesystem-oldcore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-store-filesystem-oldcore` | Maven | From 14.3-rc-1 | 14.4.6 |
| `org.xwiki.platform:xwiki-platform-store-filesystem-oldcore` | Maven | From 14.3-rc-1 | 14.4.6 |
| `org.xwiki.platform:xwiki-platform-store-filesystem-oldcore` | Maven | From 14.5 | 14.9-rc-1 |
| `org.xwiki.platform:xwiki-platform-store-filesystem-oldcore` | Maven | From 14.5 | 14.9-rc-1 |

Products: Xwiki Xwiki.

## How do I fix CVE-2023-26478?

Upgrade org.xwiki.platform:xwiki-platform-store-filesystem-oldcore to a fixed version for your release line: 14.4.6 or 14.9-rc-1.

## Is CVE-2023-26478 being exploited?

There is no known exploitation of CVE-2023-26478 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-26478 and fix it if it is affected.

What it is: CVE-2023-26478 is a medium-severity missing authorization vulnerability in Xwiki Xwiki, published on 2 Mar 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-26478 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-store-filesystem-oldcore (Maven): affected from 14.3-rc-1; fixed in 14.4.6
- org.xwiki.platform:xwiki-platform-store-filesystem-oldcore (Maven): affected from 14.3-rc-1; fixed in 14.4.6
- org.xwiki.platform:xwiki-platform-store-filesystem-oldcore (Maven): affected from 14.5; fixed in 14.9-rc-1
- org.xwiki.platform:xwiki-platform-store-filesystem-oldcore (Maven): affected from 14.5; fixed in 14.9-rc-1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-26478/ (Markdown: https://insights.sbomify.com/CVE-2023-26478/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-26478
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-26478
- OSV: https://osv.dev/vulnerability/CVE-2023-26478

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-26478/
Summaries are generated and may contain mistakes; the official description above is the record.
