# CVE-2023-26481: Insufficient user check in FlowTokens by Email stage

> An attacker can reset any user's password using an admin-generated recovery link if a specific custom flow configuration is present.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Mar 2023
- **Updated:** 25 Feb 2025
- **Also known as:** BIT-authentik-2023-26481, GHSA-3xf5-pqvf-rqq3

## What is CVE-2023-26481?

CVE-2023-26481 is a critical authentication bypass vulnerability in goauthentik authentik, published on 4 Mar 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

authentik is an open-source Identity Provider. Due to an insufficient access check, a recovery flow link that is created by an admin (or sent via email by an admin) can be used to set the password for any arbitrary user. This attack is only possible if a recovery flow exists, which has both an Identification and an Email stage bound to it. If the flow has policies on the identification stage to skip it when the flow is restored (by checking `request.context['is_restored']`), the flow is not affected by this. With this flow in place, an administrator must create a recovery Link or send a recovery URL to the attacker, who can, due to the improper validation of the token create, set the password for any account. Regardless, for custom recovery flows it is recommended to add a policy that checks if the flow is restored, and skips the identification stage. This issue has been fixed in versions 2023.2.3, 2023.1.3 and 2022.12.2.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2023-26481?

1 open source package ship an affected version, including authentik. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `authentik` | Bitnami | All versions to 2023.1.3 | 2022.12.3 |

Products: Goauthentik Authentik.

## How do I fix CVE-2023-26481?

Upgrade authentik to 2022.12.3 or later.

## Is CVE-2023-26481 being exploited?

There is no known exploitation of CVE-2023-26481 in the wild and no public exploit code.

## Other vulnerabilities in goauthentik authentik

- [CVE-2026-49448](https://insights.sbomify.com/CVE-2026-49448/): authentik: SourceStage bypass via empty POST (critical 9.8)
- [CVE-2023-46249](https://insights.sbomify.com/CVE-2023-46249/): authentik potential installation takeover when default admin user is deleted (critical 9.7)
- [CVE-2022-23555](https://insights.sbomify.com/CVE-2022-23555/): authentik vulnerable to Improper Authentication via invitation URL token reuse (critical 9.4)
- [CVE-2026-42849](https://insights.sbomify.com/CVE-2026-42849/): authentik: Reflected XSS in SFE AutosubmitStage allows IDP account takeover (critical 9.3)
- [CVE-2026-25227](https://insights.sbomify.com/CVE-2026-25227/): authentik affected by Remote Code Execution via Context Key Injection in PropertyMapping Test Endpoint (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-26481 and fix it if it is affected.

What it is: CVE-2023-26481 is a critical authentication bypass vulnerability in goauthentik authentik, published on 4 Mar 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-26481 in the wild and no public exploit code.

Affected packages and fixed versions:
- authentik (Bitnami): affected all versions up to 2023.1.3; fixed in 2022.12.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-26481/ (Markdown: https://insights.sbomify.com/CVE-2023-26481/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-26481
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-26481
- OSV: https://osv.dev/vulnerability/CVE-2023-26481

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-26481/
Summaries are generated and may contain mistakes; the official description above is the record.
