# CVE-2023-26488: OpenZeppelin Contracts contains Incorrect Calculation

> Incorrect balance calculation in ERC721Consecutive allows subsequent transfers to overflow reported balances, affecting smart contract developers using OpenZeppelin Contracts.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Mar 2023
- **Updated:** 25 Feb 2025
- **Also known as:** GHSA-878m-3g6q-594q

## What is CVE-2023-26488?

CVE-2023-26488 is a medium-severity vulnerability in openzeppelin-contracts, published on 3 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenZeppelin Contracts is a library for secure smart contract development. The ERC721Consecutive contract designed for minting NFTs in batches does not update balances when a batch has size 1 and consists of a single token. Subsequent transfers from the receiver of that token may overflow the balance as reported by `balanceOf`. The issue exclusively presents with batches of size 1. The issue has been patched in 4.8.2.

Weakness: CWE-682 (Incorrect Calculation)

## Which versions are affected by CVE-2023-26488?

4 open source packages ship an affected version, including @openzeppelin/contracts and @openzeppelin/contracts-upgradeable. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@openzeppelin/contracts` | npm | From 4.8.0 | 4.8.2 |
| `@openzeppelin/contracts` | npm | From 4.8.0 | 4.8.2 |
| `@openzeppelin/contracts-upgradeable` | npm | From 4.8.0 | 4.8.2 |
| `@openzeppelin/contracts-upgradeable` | npm | From 4.8.0 | 4.8.2 |

Products: Openzeppelin Contracts, Openzeppelin Contracts Upgradeable.

## How do I fix CVE-2023-26488?

Upgrade @openzeppelin/contracts to 4.8.2 or later.

## Is CVE-2023-26488 being exploited?

There is no known exploitation of CVE-2023-26488 in the wild and no public exploit code.

## Other vulnerabilities in openzeppelin-contracts

- [CVE-2021-39167](https://insights.sbomify.com/CVE-2021-39167/): TimelockController vulnerability in OpenZeppelin Contracts (critical 10.0)
- [CVE-2021-39168](https://insights.sbomify.com/CVE-2021-39168/): TimelockController vulnerability in OpenZeppelin Contracts (critical 10.0)
- [CVE-2021-41264](https://insights.sbomify.com/CVE-2021-41264/): UUPSUpgradeable vulnerability in OpenZeppelin Contracts (critical 9.8)
- [CVE-2022-35961](https://insights.sbomify.com/CVE-2022-35961/): ECDSA signature malleability in OpenZeppelin Contracts (high 7.9)
- [CVE-2022-31198](https://insights.sbomify.com/CVE-2022-31198/): GovernorVotesQuorumFraction updates to quorum may affect past defeated proposals in @openzeppelin/contracts (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-26488 and fix it if it is affected.

What it is: CVE-2023-26488 is a medium-severity vulnerability in openzeppelin-contracts, published on 3 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-26488 in the wild and no public exploit code.

Affected packages and fixed versions:
- @openzeppelin/contracts (npm): affected from 4.8.0; fixed in 4.8.2
- @openzeppelin/contracts (npm): affected from 4.8.0; fixed in 4.8.2
- @openzeppelin/contracts-upgradeable (npm): affected from 4.8.0; fixed in 4.8.2
- @openzeppelin/contracts-upgradeable (npm): affected from 4.8.0; fixed in 4.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-26488/ (Markdown: https://insights.sbomify.com/CVE-2023-26488/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-26488
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-26488
- OSV: https://osv.dev/vulnerability/CVE-2023-26488

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-26488/
Summaries are generated and may contain mistakes; the official description above is the record.
