{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.eventmesh:eventmesh-connector-rabbitmq. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-26512 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2023-26512 yet. Limit exposure of the affected software until one is available.","what":"CVE-2023-26512 is a critical unsafe deserialization vulnerability in Apache EventMesh (incubating) RabbitMQ connector, published on 17 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-26512 and fix it if it is affected.\n\nWhat it is: CVE-2023-26512 is a critical unsafe deserialization vulnerability in Apache EventMesh (incubating) RabbitMQ connector, published on 17 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-26512 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.eventmesh:eventmesh-connector-rabbitmq (Maven): affected from 1.7.0 up to 1.8.0; no fix listed\n- org.apache.eventmesh:eventmesh-connector-rabbitmq (Maven): affected from 1.7.0 up to 1.8.0; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-26512/ (Markdown: https://insights.sbomify.com/CVE-2023-26512/index.md)","id":"CVE-2023-26512","markdown":"https://insights.sbomify.com/CVE-2023-26512/index.md","name":"CVE-2023-26512","record":{"aliases":["GHSA-fj8f-56wc-q36r"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache EventMesh plugin","requires_auth":"none","summary":"Attackers can achieve remote code execution by sending malicious RabbitMQ messages to the Apache EventMesh RabbitMQ-Connector plugin.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"eventmesh-connector-rabbitmq","vendor":"apache"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"CWE-502 Deserialization of Untrusted Data at the rabbitmq-connector plugin module in Apache EventMesh (incubating) V1.7.0\\V1.8.0 on windows\\linux\\mac os e.g. platforms allows attackers to send controlled message and \n\nremote code execute via rabbitmq messages. Users can use the code under the master branch in project repo to fix this issue, we will release the new version as soon as possible.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Apache EventMesh RabbitMQ-Connector plugin allows RCE through deserialization of untrusted data","id":"CVE-2023-26512","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"deserialization","year":"2023"},"n_packages":2,"n_references":1,"next":{"headline":"Apache Sling Resource Merger: Requests to certain paths managed by the Apache Sling Resource Merger can lead to DoS","id":"CVE-2023-26513"},"packages":[{"ecosystem":"Maven","fixed":[],"introduced":["1.7.0"],"last_affected":["1.8.0"],"package":"org.apache.eventmesh:eventmesh-connector-rabbitmq","purl":null,"source":"GHSA-fj8f-56wc-q36r"},{"ecosystem":"Maven","fixed":[],"introduced":["1.7.0"],"last_affected":["1.8.0"],"package":"org.apache.eventmesh:eventmesh-connector-rabbitmq","purl":"pkg:maven/org.apache.eventmesh/eventmesh-connector-rabbitmq","source":"GHSA-fj8f-56wc-q36r"}],"prev":{"headline":"Hardcoded credentials in n/a","id":"CVE-2023-26511"},"products":["Apache EventMesh (incubating) RabbitMQ connector"],"published":"2023-07-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-10-02","vendors":["Apache Software Foundation"]},"summary":"Attackers can achieve remote code execution by sending malicious RabbitMQ messages to the Apache EventMesh RabbitMQ-Connector plugin.","url":"https://insights.sbomify.com/CVE-2023-26512/"}