{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.sling:org.apache.sling.resourcemerger. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-26513 in the wild and no public exploit code.","fix":"Upgrade org.apache.sling:org.apache.sling.resourcemerger to 1.4.2 or later.","what":"CVE-2023-26513 is a high-severity denial of service vulnerability in Apache Sling Resource Merger, published on 20 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-26513 and fix it if it is affected.\n\nWhat it is: CVE-2023-26513 is a high-severity denial of service vulnerability in Apache Sling Resource Merger, published on 20 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-26513 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.sling:org.apache.sling.resourcemerger (Maven): affected from 1.2.0; fixed in 1.4.2\n- org.apache.sling:org.apache.sling.resourcemerger (Maven): affected from 1.2.0; fixed in 1.4.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-26513/ (Markdown: https://insights.sbomify.com/CVE-2023-26513/index.md)","id":"CVE-2023-26513","markdown":"https://insights.sbomify.com/CVE-2023-26513/index.md","name":"CVE-2023-26513","record":{"aliases":["GHSA-rwrx-x2hw-9h5w"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Sling library","requires_auth":"none","summary":"Attackers can cause denial of service in applications using Apache Sling Resource Merger by triggering excessive iteration on specific paths.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"sling_resource_merger","vendor":"apache"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-834","name":"Excessive Iteration"}],"description":"Excessive Iteration vulnerability in Apache Software Foundation Apache Sling Resource Merger.This issue affects Apache Sling Resource Merger: from 1.2.0 before 1.4.2.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Sling Resource Merger: Requests to certain paths managed by the Apache Sling Resource Merger can lead to DoS","id":"CVE-2023-26513","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":2,"n_references":1,"next":{"headline":"WordPress XML Sitemap Generator for Google Plugin \u003c= 1.3.3 is vulnerable to Cross Site Request Forgery (CSRF)","id":"CVE-2023-26514"},"packages":[{"ecosystem":"Maven","fixed":["1.4.2"],"introduced":["1.2.0"],"last_affected":[],"package":"org.apache.sling:org.apache.sling.resourcemerger","purl":null,"source":"GHSA-rwrx-x2hw-9h5w"},{"ecosystem":"Maven","fixed":["1.4.2"],"introduced":["1.2.0"],"last_affected":[],"package":"org.apache.sling:org.apache.sling.resourcemerger","purl":"pkg:maven/org.apache.sling/org.apache.sling.resourcemerger","source":"GHSA-rwrx-x2hw-9h5w"}],"prev":{"headline":"Apache EventMesh RabbitMQ-Connector plugin allows RCE through deserialization of untrusted data","id":"CVE-2023-26512"},"products":["Apache Sling Resource Merger"],"published":"2023-03-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-13","vendors":["Apache Software Foundation"]},"summary":"Attackers can cause denial of service in applications using Apache Sling Resource Merger by triggering excessive iteration on specific paths.","url":"https://insights.sbomify.com/CVE-2023-26513/"}