# CVE-2023-26513: Apache Sling Resource Merger: Requests to certain paths managed by the Apache Sling Resource Merger can lead to DoS

> Attackers can cause denial of service in applications using Apache Sling Resource Merger by triggering excessive iteration on specific paths.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2023
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-rwrx-x2hw-9h5w

## What is CVE-2023-26513?

CVE-2023-26513 is a high-severity denial of service vulnerability in Apache Sling Resource Merger, published on 20 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Excessive Iteration vulnerability in Apache Software Foundation Apache Sling Resource Merger.This issue affects Apache Sling Resource Merger: from 1.2.0 before 1.4.2.

Weakness: CWE-834 (Excessive Iteration)

## Which versions are affected by CVE-2023-26513?

2 open source packages ship an affected version, including org.apache.sling:org.apache.sling.resourcemerger. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.sling:org.apache.sling.resourcemerger` | Maven | From 1.2.0 | 1.4.2 |
| `org.apache.sling:org.apache.sling.resourcemerger` | Maven | From 1.2.0 | 1.4.2 |

Products: Apache Sling Resource Merger.

## How do I fix CVE-2023-26513?

Upgrade org.apache.sling:org.apache.sling.resourcemerger to 1.4.2 or later.

## Is CVE-2023-26513 being exploited?

There is no known exploitation of CVE-2023-26513 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-26513 and fix it if it is affected.

What it is: CVE-2023-26513 is a high-severity denial of service vulnerability in Apache Sling Resource Merger, published on 20 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-26513 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.sling:org.apache.sling.resourcemerger (Maven): affected from 1.2.0; fixed in 1.4.2
- org.apache.sling:org.apache.sling.resourcemerger (Maven): affected from 1.2.0; fixed in 1.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-26513/ (Markdown: https://insights.sbomify.com/CVE-2023-26513/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-26513
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-26513
- OSV: https://osv.dev/vulnerability/CVE-2023-26513

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-26513/
Summaries are generated and may contain mistakes; the official description above is the record.
