# CVE-2023-26964: h2 vulnerable to denial of service

> Attackers can cause high memory and CPU usage leading to Denial of Service by sending crafted HTTP2 RST_STREAM frames to applications using the hyper library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Apr 2023
- **Updated:** 11 Feb 2025
- **Also known as:** AZL-26291, AZL-26730, AZL-34823, AZL-35217, AZL-61174, DEBIAN-CVE-2023-26964, GHSA-f8vr-r385-rh5r, RUSTSEC-2023-0034, UBUNTU-CVE-2023-26964, openSUSE-SU-2024:12859-1, openSUSE-SU-2024:12861-1, openSUSE-SU-2024:12862-1, openSUSE-SU-2024:12863-1, openSUSE-SU-2024:12864-1, openSUSE-SU-2024:12866-1, openSUSE-SU-2024:12960-1, openSUSE-SU-2024:12973-1, openSUSE-SU-2024:13106-1

## What is CVE-2023-26964?

CVE-2023-26964 is a high-severity denial of service vulnerability in n/a, published on 11 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in hyper v0.13.7. h2-0.2.4 Stream stacking occurs when the H2 component processes HTTP2 RST_STREAM frames. As a result, the memory and CPU usage are high which can lead to a Denial of Service (DoS).

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2023-26964?

3 open source packages ship an affected version, including h2. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `h2` | crates.io | All versions | 0.3.17 |
| `h2` | crates.io | All versions | 0.3.17 |
| `h2` | crates.io | From 0.0.0-0 | 0.3.17 |
| `hoard` | openSUSE:Tumbleweed | All versions | v.1.4.2~0-1.1 |
| `pijul` | openSUSE:Tumbleweed | All versions | 1.0.0~beta.5-1.1 |
| `rustup` | openSUSE:Tumbleweed | All versions | 1.25.2~0-4.1 |
| `sccache` | openSUSE:Tumbleweed | All versions | 0.4.1~18-2.1 |
| `wasm-pack` | openSUSE:Tumbleweed | All versions | 0.11.0~0-2.1 |
| `watchexec` | openSUSE:Tumbleweed | All versions | 1.22.3-1.1 |

Products: Hyper H2, Hyper Hyper.

## How do I fix CVE-2023-26964?

Upgrade h2 to 0.3.17 or later.

## Is CVE-2023-26964 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26964 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-26964 and fix it if it is affected.

What it is: CVE-2023-26964 is a high-severity denial of service vulnerability in n/a, published on 11 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-26964 exists.

Affected packages and fixed versions:
- h2 (crates.io): affected all versions; fixed in 0.3.17
- h2 (crates.io): affected all versions; fixed in 0.3.17
- h2 (crates.io): affected from 0.0.0-0; fixed in 0.3.17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-26964/ (Markdown: https://insights.sbomify.com/CVE-2023-26964/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-26964
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-26964
- OSV: https://osv.dev/vulnerability/CVE-2023-26964

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-26964/
Summaries are generated and may contain mistakes; the official description above is the record.
