CVE-2023-27372 Deserialization in n/a

Critical 9.8 Published Updated

Remote attackers can execute arbitrary code on SPIP CMS instances by exploiting unsafe deserialization of form values in public areas.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-27372?

CVE-2023-27372 is a critical unsafe deserialization vulnerability in Debian Debian Linux, published on 28 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

SPIP before 4.2.1 allows Remote Code Execution via form values in the public area because serialization is mishandled. The fixed versions are 3.2.18, 4.0.10, 4.1.8, and 4.2.1.

Weakness: CWE-502

Which versions are affected by CVE-2023-27372?

It affects 2 products.

Products include Debian Debian Linux, Spip Spip.

How do I fix CVE-2023-27372?

Upgrade to a fixed version.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2023-27372 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-27372 exists.

Public exploit code: 1 Metasploit module, 1 Exploit-DB entry, 1 Nuclei template and 13 proofs of concept on GitHub.

All Debian Debian Linux vulnerabilities

Sources

Also known as DEBIAN-CVE-2023-27372, DSA-5367-1, GHSA-jc3f-vxgp-6jw9, UBUNTU-CVE-2023-27372.

Is CVE-2023-27372 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free