# CVE-2023-27372: Deserialization in n/a

> Remote attackers can execute arbitrary code on SPIP CMS instances by exploiting unsafe deserialization of form values in public areas.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Feb 2023
- **Updated:** 11 Mar 2025
- **Also known as:** DEBIAN-CVE-2023-27372, DSA-5367-1, GHSA-jc3f-vxgp-6jw9, UBUNTU-CVE-2023-27372

## What is CVE-2023-27372?

CVE-2023-27372 is a critical unsafe deserialization vulnerability in Debian Debian Linux, published on 28 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SPIP before 4.2.1 allows Remote Code Execution via form values in the public area because serialization is mishandled. The fixed versions are 3.2.18, 4.0.10, 4.1.8, and 4.2.1.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2023-27372?

It affects 2 products.


Products: Debian Debian Linux, Spip Spip.

## How do I fix CVE-2023-27372?

Upgrade to a fixed version.

## Is CVE-2023-27372 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-27372 exists.

Public exploit code:

- SPIP before 4.2.1 allows Remote Code Execution via form values in the public area because serialization is mishandled. The fixed versions are 3.2.18, 4.0.10, 4.1.8, and 4.2.1. (github_poc): https://github.com/nuts7/CVE-2023-27372
- SPIP Vulnerability Scanner - CVE-2023-27372 Detector (github_poc): https://github.com/Chocapikk/CVE-2023-27372
- This is a PoC for CVE-2023-27372 which spawns a fully interactive shell.  (github_poc): https://github.com/0SPwn/CVE-2023-27372-PoC
- Perform With Mass Remote Code Execution In SPIP Version (4.2.1) (github_poc): https://github.com/Ap0dexMe0/CVE-2023-27372
- CVE-2023-27372-SPIP-CMS-Bypass (github_poc): https://github.com/izzz0/CVE-2023-27372-POC
- SPIP CVE-2023-27372 Unauthenticated RCE Exploit (Web Shell Upload) (github_poc): https://github.com/1Ronkkeli/spip-cve-2023-27372-rce

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-27372 and fix it if it is affected.

What it is: CVE-2023-27372 is a critical unsafe deserialization vulnerability in Debian Debian Linux, published on 28 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-27372 exists.

Affected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-27372/ (Markdown: https://insights.sbomify.com/CVE-2023-27372/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-27372
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-27372
- OSV: https://osv.dev/vulnerability/CVE-2023-27372

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-27372/
Summaries are generated and may contain mistakes; the official description above is the record.
