CVE-2023-2745 WordPress Core < 6.2.1 - Directory Traversal
Unauthenticated attackers can exploit directory traversal to read arbitrary translation files and potentially execute code via XSS if they can upload crafted files.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-2745?
CVE-2023-2745 is a medium-severity path traversal vulnerability in Wordpress Wordpress, published on 17 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
WordPress Core is vulnerable to Directory Traversal in versions up to, and including, 6.2, via the ‘wp_lang’ parameter. This allows unauthenticated attackers to access and load arbitrary translation files. In cases where an attacker is able to upload a crafted translation file onto the site, such as via an upload form, this could be also used to perform a Cross-Site Scripting attack.
Weakness: CWE-22
Which versions are affected by CVE-2023-2745?
2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
wordpress Bitnami | All versions | 4.1.38, 4.2.35, 4.3.31, 4.4.30, 4.5.29, 4.6.26, 4.7.26, 4.8.22, 4.9.23, 5.0.19, 5.1.16, 5.2.18, 5.3.15, 5.4.13, 5.5.12, 5.6.11, 5.7.9, 5.8.7, 5.9.6, 6.0.4, 6.1.2, 6.2.1 |
wordpress-multisite Bitnami | All versions | 4.1.38, 4.2.35, 4.3.31, 4.4.30, 4.5.29, 4.6.26, 4.7.26, 4.8.22, 4.9.23, 5.0.19, 5.1.16, 5.2.18, 5.3.15, 5.4.13, 5.5.12, 5.6.11, 5.7.9, 5.8.7, 5.9.6, 6.0.4, 6.1.2, 6.2.1 |
Products include Wordpress Wordpress.
How do I fix CVE-2023-2745?
Upgrade wordpress to a fixed version for your release line: 4.1.38, 4.2.35, 4.3.31 or 4.4.30.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2023-2745 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-2745 exists.
Public exploit code: 1 Exploit-DB entry, 1 Nuclei template and 1 proofs of concept on GitHub.
Other vulnerabilities in Wordpress Wordpress
Sources
Also known as BIT-wordpress-2023-2745, BIT-wordpress-multisite-2023-2745, DEBIAN-CVE-2023-2745, DLA-3462-1, GHSA-xgqr-2mpj-w9qv, UBUNTU-CVE-2023-2745.