{"answers":{"affected":"2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-2745 exists.","fix":"Upgrade wordpress to a fixed version for your release line: 4.1.38, 4.2.35, 4.3.31 or 4.4.30.","what":"CVE-2023-2745 is a medium-severity path traversal vulnerability in Wordpress Wordpress, published on 17 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-2745 and fix it if it is affected.\n\nWhat it is: CVE-2023-2745 is a medium-severity path traversal vulnerability in Wordpress Wordpress, published on 17 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-2745 exists.\n\nAffected packages and fixed versions:\n- wordpress (Bitnami): affected all versions; fixed in 4.1.38, 4.2.35, 4.3.31, 4.4.30, 4.5.29, 4.6.26, 4.7.26, 4.8.22, 4.9.23, 5.0.19, 5.1.16, 5.2.18, 5.3.15, 5.4.13, 5.5.12, 5.6.11, 5.7.9, 5.8.7, 5.9.6, 6.0.4, 6.1.2, 6.2.1\n- wordpress-multisite (Bitnami): affected all versions; fixed in 4.1.38, 4.2.35, 4.3.31, 4.4.30, 4.5.29, 4.6.26, 4.7.26, 4.8.22, 4.9.23, 5.0.19, 5.1.16, 5.2.18, 5.3.15, 5.4.13, 5.5.12, 5.6.11, 5.7.9, 5.8.7, 5.9.6, 6.0.4, 6.1.2, 6.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-2745/ (Markdown: https://insights.sbomify.com/CVE-2023-2745/index.md)","id":"CVE-2023-2745","markdown":"https://insights.sbomify.com/CVE-2023-2745/index.md","name":"CVE-2023-2745","record":{"aliases":["BIT-wordpress-2023-2745","BIT-wordpress-multisite-2023-2745","DEBIAN-CVE-2023-2745","DLA-3462-1","GHSA-xgqr-2mpj-w9qv","UBUNTU-CVE-2023-2745"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress Core","requires_auth":"none","summary":"Unauthenticated attackers can exploit directory traversal to read arbitrary translation files and potentially execute code via XSS if they can upload crafted files.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[{"product":"wordpress","vendor":"wordpress"}],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"WordPress Core is vulnerable to Directory Traversal in versions up to, and including, 6.2, via the ‘wp_lang’ parameter. This allows unauthenticated attackers to access and load arbitrary translation files. In cases where an attacker is able to upload a crafted translation file onto the site, such as via an upload form, this could be also used to perform a Cross-Site Scripting attack.","ecosystems":["Bitnami"],"exploits":{"exploitdb":1,"first_seen":"2025-04-22","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":1,"refs":[{"date":"2025-04-22","kind":"exploitdb","ref":"52274","stars":null,"title":"WordPress Core 6.2 - Directory Traversal"},{"date":"2025-10-22T21:41:08Z","kind":"github_poc","ref":"https://github.com/fofovicfof-ai/cve-2023-2745","stars":0,"title":"cve-2023-2745"},{"date":null,"kind":"nuclei","ref":"http/cves/2023/CVE-2023-2745.yaml","stars":null,"title":"WordPress Core \u003c=6.2 - Directory Traversal"}],"tier":"weaponised"},"has_fix":true,"headline":"WordPress Core \u003c 6.2.1 - Directory Traversal","id":"CVE-2023-2745","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"wordpress:wordpress","products":["wordpress:wordpress"],"type":"path_traversal","year":"2023"},"n_packages":2,"n_references":4,"next":{"headline":"Rockwell Automation Enhanced HIM Vulnerable to Cross-Site Request Forgery Attack","id":"CVE-2023-2746"},"packages":[{"ecosystem":"Bitnami","fixed":["4.1.38","4.2.35","4.3.31","4.4.30","4.5.29","4.6.26","4.7.26","4.8.22","4.9.23","5.0.19","5.1.16","5.2.18","5.3.15","5.4.13","5.5.12","5.6.11","5.7.9","5.8.7","5.9.6","6.0.4","6.1.2","6.2.1"],"introduced":["0","4.2.0","4.3.0","4.4.0","4.5.0","4.6.0","4.7.0","4.8.0","4.9.0","5.0.0","5.1.0","5.2.0","5.3.0","5.4.0","5.5.0","5.6.0","5.7.0","5.8.0","5.9.0","6.0.0","6.1.0","6.2.0"],"last_affected":[],"package":"wordpress","purl":"pkg:bitnami/wordpress","source":"BIT-wordpress-2023-2745"},{"ecosystem":"Bitnami","fixed":["4.1.38","4.2.35","4.3.31","4.4.30","4.5.29","4.6.26","4.7.26","4.8.22","4.9.23","5.0.19","5.1.16","5.2.18","5.3.15","5.4.13","5.5.12","5.6.11","5.7.9","5.8.7","5.9.6","6.0.4","6.1.2","6.2.1"],"introduced":["0","4.2.0","4.3.0","4.4.0","4.5.0","4.6.0","4.7.0","4.8.0","4.9.0","5.0.0","5.1.0","5.2.0","5.3.0","5.4.0","5.5.0","5.6.0","5.7.0","5.8.0","5.9.0","6.0.0","6.1.0","6.2.0"],"last_affected":[],"package":"wordpress-multisite","purl":"pkg:bitnami/wordpress-multisite","source":"BIT-wordpress-multisite-2023-2745"}],"prev":{"headline":"WP ERP \u003c 1.12.4 - Admin+ SQL Injection","id":"CVE-2023-2744"},"products":["WordPress"],"published":"2023-05-17","related":[{"cvss_score":9.8,"headline":"WordPress Core Interpretation Conflict","id":"CVE-2026-63030","kev_date_added":"2026-07-21","published":"2026-07-17"},{"cvss_score":8.1,"headline":"WordPress Core Remote File Inclusion","id":"CVE-2026-87902","kev_date_added":"2026-09-25","published":"2026-09-22"},{"cvss_score":5.9,"headline":"WordPress Core SQL Injection","id":"CVE-2026-60137","kev_date_added":"2026-07-21","published":"2026-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2012-2399","kev_date_added":null,"published":"2012-04-21"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2012-2400","kev_date_added":null,"published":"2012-04-21"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2011-3122","kev_date_added":null,"published":"2011-08-10"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2011-3125","kev_date_added":null,"published":"2011-08-10"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["WordPress Foundation"]},"summary":"Unauthenticated attackers can exploit directory traversal to read arbitrary translation files and potentially execute code via XSS if they can upload crafted files.","url":"https://insights.sbomify.com/CVE-2023-2745/"}