# CVE-2023-2745: WordPress Core < 6.2.1 - Directory Traversal

> Unauthenticated attackers can exploit directory traversal to read arbitrary translation files and potentially execute code via XSS if they can upload crafted files.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 May 2023
- **Updated:** 8 Apr 2026
- **Also known as:** BIT-wordpress-2023-2745, BIT-wordpress-multisite-2023-2745, DEBIAN-CVE-2023-2745, DLA-3462-1, GHSA-xgqr-2mpj-w9qv, UBUNTU-CVE-2023-2745

## What is CVE-2023-2745?

CVE-2023-2745 is a medium-severity path traversal vulnerability in Wordpress Wordpress, published on 17 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

WordPress Core is vulnerable to Directory Traversal in versions up to, and including, 6.2, via the ‘wp_lang’ parameter. This allows unauthenticated attackers to access and load arbitrary translation files. In cases where an attacker is able to upload a crafted translation file onto the site, such as via an upload form, this could be also used to perform a Cross-Site Scripting attack.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2023-2745?

2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wordpress` | Bitnami | All versions | 4.1.38, 4.2.35, 4.3.31, 4.4.30, 4.5.29, 4.6.26, 4.7.26, 4.8.22, 4.9.23, 5.0.19, 5.1.16, 5.2.18, 5.3.15, 5.4.13, 5.5.12, 5.6.11, 5.7.9, 5.8.7, 5.9.6, 6.0.4, 6.1.2, 6.2.1 |
| `wordpress-multisite` | Bitnami | All versions | 4.1.38, 4.2.35, 4.3.31, 4.4.30, 4.5.29, 4.6.26, 4.7.26, 4.8.22, 4.9.23, 5.0.19, 5.1.16, 5.2.18, 5.3.15, 5.4.13, 5.5.12, 5.6.11, 5.7.9, 5.8.7, 5.9.6, 6.0.4, 6.1.2, 6.2.1 |

Products: Wordpress Wordpress.

## How do I fix CVE-2023-2745?

Upgrade wordpress to a fixed version for your release line: 4.1.38, 4.2.35, 4.3.31 or 4.4.30.

## Is CVE-2023-2745 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-2745 exists.

Public exploit code:

- WordPress Core 6.2 - Directory Traversal (exploitdb)
- cve-2023-2745 (github_poc): https://github.com/fofovicfof-ai/cve-2023-2745
- WordPress Core <=6.2 - Directory Traversal (nuclei): http/cves/2023/CVE-2023-2745.yaml

## Other vulnerabilities in Wordpress Wordpress

- [CVE-2026-63030](https://insights.sbomify.com/CVE-2026-63030/): WordPress Core Interpretation Conflict (critical 9.8, exploited in the wild)
- [CVE-2026-87902](https://insights.sbomify.com/CVE-2026-87902/): WordPress Core Remote File Inclusion (high 8.1, exploited in the wild)
- [CVE-2026-60137](https://insights.sbomify.com/CVE-2026-60137/): WordPress Core SQL Injection (medium 5.9, exploited in the wild)
- [CVE-2012-2399](https://insights.sbomify.com/CVE-2012-2399/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2012-2400](https://insights.sbomify.com/CVE-2012-2400/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-2745 and fix it if it is affected.

What it is: CVE-2023-2745 is a medium-severity path traversal vulnerability in Wordpress Wordpress, published on 17 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-2745 exists.

Affected packages and fixed versions:
- wordpress (Bitnami): affected all versions; fixed in 4.1.38, 4.2.35, 4.3.31, 4.4.30, 4.5.29, 4.6.26, 4.7.26, 4.8.22, 4.9.23, 5.0.19, 5.1.16, 5.2.18, 5.3.15, 5.4.13, 5.5.12, 5.6.11, 5.7.9, 5.8.7, 5.9.6, 6.0.4, 6.1.2, 6.2.1
- wordpress-multisite (Bitnami): affected all versions; fixed in 4.1.38, 4.2.35, 4.3.31, 4.4.30, 4.5.29, 4.6.26, 4.7.26, 4.8.22, 4.9.23, 5.0.19, 5.1.16, 5.2.18, 5.3.15, 5.4.13, 5.5.12, 5.6.11, 5.7.9, 5.8.7, 5.9.6, 6.0.4, 6.1.2, 6.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-2745/ (Markdown: https://insights.sbomify.com/CVE-2023-2745/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-2745
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-2745
- OSV: https://osv.dev/vulnerability/CVE-2023-2745

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-2745/
Summaries are generated and may contain mistakes; the official description above is the record.
