# CVE-2023-27475: Goutil vulnerable to path traversal when unzipping files

> Attackers can exploit path traversal in the Goutil library's unzip function to write files outside the intended directory, potentially leading to code execution.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Mar 2023
- **Updated:** 25 Feb 2025
- **Also known as:** GHSA-fx2v-qfhr-4chv, GO-2023-1611

## What is CVE-2023-27475?

CVE-2023-27475 is a high-severity path traversal vulnerability in gookit goutil, published on 7 Mar 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Goutil is a collection of miscellaneous functionality for the go language. In versions prior to 0.6.0 when users use fsutil.Unzip to unzip zip files from a malicious attacker, they may be vulnerable to path traversal. This vulnerability is known as a ZipSlip. This issue has been fixed in version 0.6.0, users are advised to upgrade. There are no known workarounds for this issue.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2023-27475?

3 open source packages ship an affected version, including github.com/gookit/goutil. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/gookit/goutil` | Go | All versions | 0.6.0 |
| `github.com/gookit/goutil` | Go | All versions | 0.6.0 |
| `github.com/gookit/goutil` | Go | All versions | 0.6.7 |

Products: Goutil Project Goutil.

## How do I fix CVE-2023-27475?

Upgrade github.com/gookit/goutil to a fixed version for your release line: 0.6.0 or 0.6.7.

## Is CVE-2023-27475 being exploited?

There is no known exploitation of CVE-2023-27475 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-27475 and fix it if it is affected.

What it is: CVE-2023-27475 is a high-severity path traversal vulnerability in gookit goutil, published on 7 Mar 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-27475 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/gookit/goutil (Go): affected all versions; fixed in 0.6.0
- github.com/gookit/goutil (Go): affected all versions; fixed in 0.6.0
- github.com/gookit/goutil (Go): affected all versions; fixed in 0.6.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-27475/ (Markdown: https://insights.sbomify.com/CVE-2023-27475/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-27475
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-27475
- OSV: https://osv.dev/vulnerability/CVE-2023-27475

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-27475/
Summaries are generated and may contain mistakes; the official description above is the record.
