# CVE-2023-27478: Disclosure of unrelated data in libmemcached-awesome

> An attacker can read unrelated cached data if a previous request timed out due to a low POLL_TIMEOUT setting in libmemcached-awesome.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Mar 2023
- **Updated:** 25 Feb 2025
- **Also known as:** AZL-25584, AZL-34932, BIT-libmemcached-2023-27478, BIT-memcached-2023-27478, DEBIAN-CVE-2023-27478, GHSA-wwmh-39wj-fx59

## What is CVE-2023-27478?

CVE-2023-27478 is a medium-severity vulnerability in awesomized libmemcached, published on 7 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

libmemcached-awesome is an open source C/C++ client library and tools for the memcached server. `libmemcached` could return data for a previously requested key, if that previous request timed out due to a low `POLL_TIMEOUT`. This issue has been addressed in version 1.1.4. Users are advised to upgrade. There are several ways to workaround or lower the probability of this bug affecting a given deployment. 1: use a reasonably high `POLL_TIMEOUT` setting, like the default. 2: use separate libmemcached connections for unrelated data. 3: do not re-use libmemcached connections in an unknown state.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2023-27478?

2 open source packages ship an affected version, including libmemcached and memcached. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libmemcached` | Bitnami | From 1.0.18 | 1.1.4 |
| `memcached` | Bitnami | From 1.0.18 | 1.1.4 |

Products: Awesome Libmemcached.

## How do I fix CVE-2023-27478?

Upgrade libmemcached to 1.1.4 or later.

## Is CVE-2023-27478 being exploited?

There is no known exploitation of CVE-2023-27478 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-27478 and fix it if it is affected.

What it is: CVE-2023-27478 is a medium-severity vulnerability in awesomized libmemcached, published on 7 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-27478 in the wild and no public exploit code.

Affected packages and fixed versions:
- libmemcached (Bitnami): affected from 1.0.18; fixed in 1.1.4
- memcached (Bitnami): affected from 1.0.18; fixed in 1.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-27478/ (Markdown: https://insights.sbomify.com/CVE-2023-27478/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-27478
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-27478
- OSV: https://osv.dev/vulnerability/CVE-2023-27478

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-27478/
Summaries are generated and may contain mistakes; the official description above is the record.
