# CVE-2023-27479: Improper Neutralization of Directives in Dynamically Evaluated Code in org.xwiki.platform:xwiki-platform-panels-ui

> Authenticated users with view rights can execute arbitrary code via improper escaping in UIX parameters, leading to full system access.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Mar 2023
- **Updated:** 25 Feb 2025
- **Also known as:** GHSA-qxjg-jhgw-qhrv

## What is CVE-2023-27479?

CVE-2023-27479 is a critical code injection vulnerability in Xwiki Xwiki, published on 7 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. In affected versions any user with view rights can execute arbitrary Groovy, Python or Velocity code in XWiki leading to full access to the XWiki installation. The root cause is improper escaping of UIX parameters. A proof of concept exploit is to log in, add an `XWiki.UIExtensionClass` xobject to the user profile page, with an Extension Parameters content containing `label={{/html}} {{async async="true" cached="false" context="doc.reference"}}{{groovy}}println("Hello " + "from groovy!"){{/groovy}}{{/async}}`. Then, navigating to `PanelsCode.ApplicationsPanelConfigurationSheet` (i.e., `<xwiki-host>/xwiki/bin/view/PanelsCode/ApplicationsPanelConfigurationSheet` where `<xwiki-host>` is the URL of your XWiki installation) should not execute the Groovy script. If it does, you will see `Hello from groovy!` displayed on the screen. This vulnerability has been patched in XWiki 13.10.11, 14.4.7 and 14.10-rc-1. Users are advised to upgrade. For users unable to upgrade the issue can be fixed by editing the `PanelsCode.ApplicationsPanelConfigurationSheet` wiki page and making the same modifications  as shown in commit `6de5442f3c`.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2023-27479?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-panels-ui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-panels-ui` | Maven | From 14.0 | 14.4.7 |
| `org.xwiki.platform:xwiki-platform-panels-ui` | Maven | From 14.0 | 14.4.7 |
| `org.xwiki.platform:xwiki-platform-panels-ui` | Maven | From 14.5 | 14.10-rc-1 |
| `org.xwiki.platform:xwiki-platform-panels-ui` | Maven | From 14.5 | 14.10-rc-1 |
| `org.xwiki.platform:xwiki-platform-panels-ui` | Maven | From 6.3-milestone-2 | 13.10.11 |
| `org.xwiki.platform:xwiki-platform-panels-ui` | Maven | From 6.3-milestone-2 | 13.10.11 |

Products: Xwiki Xwiki.

## How do I fix CVE-2023-27479?

Upgrade org.xwiki.platform:xwiki-platform-panels-ui to a fixed version for your release line: 14.4.7, 14.10-rc-1 or 13.10.11.

## Is CVE-2023-27479 being exploited?

There is no known exploitation of CVE-2023-27479 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-27479 and fix it if it is affected.

What it is: CVE-2023-27479 is a critical code injection vulnerability in Xwiki Xwiki, published on 7 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-27479 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-panels-ui (Maven): affected from 14.0; fixed in 14.4.7
- org.xwiki.platform:xwiki-platform-panels-ui (Maven): affected from 14.0; fixed in 14.4.7
- org.xwiki.platform:xwiki-platform-panels-ui (Maven): affected from 14.5; fixed in 14.10-rc-1
- org.xwiki.platform:xwiki-platform-panels-ui (Maven): affected from 14.5; fixed in 14.10-rc-1
- org.xwiki.platform:xwiki-platform-panels-ui (Maven): affected from 6.3-milestone-2; fixed in 13.10.11
- org.xwiki.platform:xwiki-platform-panels-ui (Maven): affected from 6.3-milestone-2; fixed in 13.10.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-27479/ (Markdown: https://insights.sbomify.com/CVE-2023-27479/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-27479
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-27479
- OSV: https://osv.dev/vulnerability/CVE-2023-27479

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-27479/
Summaries are generated and may contain mistakes; the official description above is the record.
