# CVE-2023-27486: Insufficient authorization validation between zones when xCAT zones are enabled

> Local root users can bypass zone restrictions to obtain SSH credentials for nodes in other zones, requiring the optional zones feature to be enabled.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 8 Mar 2023
- **Updated:** 25 Feb 2025
- **Also known as:** GHSA-hpxg-7428-6jvv

## What is CVE-2023-27486?

CVE-2023-27486 is a high-severity missing authorization vulnerability in xcat2 xcat-core, published on 8 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

xCAT is a toolkit for deployment and administration of computer clusters. In versions prior to 2.16.5 if zones are configured as a mechanism to secure clusters in XCAT, it is possible for a local root user from one node to obtain credentials to SSH to any node in any zone, except the management node of the default zone. XCAT zones are not enabled by default. Only users that use the optional zone feature are impacted. All versions of xCAT prior to xCAT 2.16.5 are vulnerable. This problem has been fixed in xCAT 2.16.5. Users making use of zones should upgrade to 2.16.5. Users unable to upgrade may mitigate the issue by disabling zones or patching the management node with the fix contained in commit `85149c37f49`.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2023-27486?

It affects 1 product.


Products: Xcat Project Xcat.

## How do I fix CVE-2023-27486?

No fix has been published for CVE-2023-27486 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-27486 being exploited?

There is no known exploitation of CVE-2023-27486 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-27486 and fix it if it is affected.

What it is: CVE-2023-27486 is a high-severity missing authorization vulnerability in xcat2 xcat-core, published on 8 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-27486 in the wild and no public exploit code.

Affected product: xcat2 xcat-core. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-27486/ (Markdown: https://insights.sbomify.com/CVE-2023-27486/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-27486
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-27486
- OSV: https://osv.dev/vulnerability/CVE-2023-27486

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-27486/
Summaries are generated and may contain mistakes; the official description above is the record.
