{"answers":{"affected":"2 open source packages ship an affected version, including next-auth. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-27490 in the wild and no public exploit code.","fix":"Upgrade next-auth to 4.20.1 or later.","what":"CVE-2023-27490 is a high-severity authentication bypass vulnerability in nextauthjs next-auth, published on 9 Mar 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-27490 and fix it if it is affected.\n\nWhat it is: CVE-2023-27490 is a high-severity authentication bypass vulnerability in nextauthjs next-auth, published on 9 Mar 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-27490 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- next-auth (npm): affected all versions; fixed in 4.20.1\n- next-auth (npm): affected all versions; fixed in 4.20.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-27490/ (Markdown: https://insights.sbomify.com/CVE-2023-27490/index.md)","id":"CVE-2023-27490","markdown":"https://insights.sbomify.com/CVE-2023-27490/index.md","name":"CVE-2023-27490","record":{"aliases":["GHSA-7r7x-4c4q-c4qf"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Next.js authentication library","requires_auth":"none","summary":"Attackers can bypass OAuth security checks to log in as victims by intercepting or manipulating authorization URLs in next-auth applications.","user_interaction":"required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"next-auth","vendor":"nextauth.js"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-384","name":"Session Fixation"},{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"NextAuth.js is an open source authentication solution for Next.js applications. `next-auth` applications using OAuth provider versions before `v4.20.1` have been found to be subject to an authentication vulnerability. A bad actor who can read traffic on the victim's network or who is able to social engineer the victim to click a manipulated login link could intercept and tamper with the authorization URL to **log in as the victim**, bypassing the CSRF protection. This is due to a partial failure during a compromised OAuth session where a session code is erroneously generated. This issue has been addressed in version 4.20.1. Users are advised to upgrade. Users unable to upgrade may using Advanced Initialization, manually check the callback request for state, pkce, and nonce against the provider configuration to prevent this issue. See the linked GHSA for details.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Missing proper state, nonce and PKCE checks for OAuth authentication in next-auth","id":"CVE-2023-27490","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"auth_bypass","year":"2023"},"n_packages":2,"n_references":7,"next":{"headline":"Envoy forwards invalid Http2/Http3 downstream headers","id":"CVE-2023-27491"},"packages":[{"ecosystem":"npm","fixed":["4.20.1"],"introduced":["0"],"last_affected":[],"package":"next-auth","purl":null,"source":"GHSA-7r7x-4c4q-c4qf"},{"ecosystem":"npm","fixed":["4.20.1"],"introduced":["0"],"last_affected":[],"package":"next-auth","purl":"pkg:npm/next-auth","source":"GHSA-7r7x-4c4q-c4qf"}],"prev":{"headline":"Stored cross site scripting via SVG file upload in Kiwi TCMS","id":"CVE-2023-27489"},"products":["next-auth"],"published":"2023-03-09","related":[{"cvss_score":9.1,"headline":"Verification requests (magic link) sent to unwanted emails","id":"CVE-2022-35924","kev_date_added":null,"published":"2022-08-02"},{"cvss_score":7.5,"headline":"Improper Handling of `callbackUrl` parameter in next-auth","id":"CVE-2022-31093","kev_date_added":null,"published":"2022-06-27"},{"cvss_score":7.1,"headline":"Improper handling of email input in next-auth","id":"CVE-2022-31127","kev_date_added":null,"published":"2022-07-06"},{"cvss_score":6.8,"headline":"NextAuth.js Upstash Adapter missing token verification","id":"CVE-2022-39263","kev_date_added":null,"published":"2022-09-28"},{"cvss_score":6.1,"headline":"URL Redirection to Untrusted Site ('Open Redirect') in next-auth","id":"CVE-2022-29214","kev_date_added":null,"published":"2022-05-20"},{"cvss_score":6.1,"headline":"Default redirect callback vulnerable to open redirects","id":"CVE-2022-24858","kev_date_added":null,"published":"2022-04-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-02-25","vendors":["nextauthjs"]},"summary":"Attackers can bypass OAuth security checks to log in as victims by intercepting or manipulating authorization URLs in next-auth applications.","url":"https://insights.sbomify.com/CVE-2023-27490/"}